summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Shatunov2020-02-02 04:41:53 +0800
committerSergey Shatunov2020-02-02 04:41:53 +0800
commit71d4e345a6bb7333c066836763097014b49b899c (patch)
tree13410c5e3499f85e268d0c9d6a36698e82c32364
parent41f1745de0adf704cf51801ecd9e9e4ef5ef451b (diff)
downloadaur-71d4e345a6bb7333c066836763097014b49b899c.tar.gz
Add leading slash to kernel path for uak-script
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xuak-script8
3 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23b3d754a359..10971c712add 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = unifed-arch-kernel
pkgdesc = Generates unifed archlinux images using pacman power
- pkgver = 0.0.4
+ pkgver = 0.0.5
pkgrel = 1
url = https://aur.archlinux.org/packages/unifed-arch-kernel/
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = unifed-arch-kernel
source = 55-unifed-arch-kernel-remove.hook
source = 75-sign-for-secure-boot.install
source = 95-unifed-arch-kernel-install.hook
- md5sums = 2ffcf000edef6ab1e85f62c3e5f910c4
+ md5sums = 3c73ba36f7238f359d5dc43fc6d95623
md5sums = 15d02966c33006a8f9dc6456953e3a47
md5sums = cf19112a5294756657e8e2e3ebf6226d
md5sums = 5b263fc13f06b08b3714337e28f44424
diff --git a/PKGBUILD b/PKGBUILD
index 65511bcd9313..91d1cc415cc2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=('unifed-arch-kernel' 'unifed-arch-kernel-secure-boot')
pkgbase=unifed-arch-kernel
-pkgver=0.0.4
+pkgver=0.0.5
pkgrel=1
pkgdesc='Generates unifed archlinux images using pacman power'
arch=(x86_64)
@@ -15,7 +15,7 @@ source=('uak-script'
'55-unifed-arch-kernel-remove.hook'
'75-sign-for-secure-boot.install'
'95-unifed-arch-kernel-install.hook')
-md5sums=('2ffcf000edef6ab1e85f62c3e5f910c4'
+md5sums=('3c73ba36f7238f359d5dc43fc6d95623'
'15d02966c33006a8f9dc6456953e3a47'
'cf19112a5294756657e8e2e3ebf6226d'
'5b263fc13f06b08b3714337e28f44424'
diff --git a/uak-script b/uak-script
index e91ca12eb646..2950d4a1a450 100755
--- a/uak-script
+++ b/uak-script
@@ -90,7 +90,9 @@ elif [[ $ACTION != "install" ]] && [[ $ACTION != "remove" ]]; then
exit 1
else
while read -r line; do
- if [[ $line != */vmlinuz ]]; then
+ kernel="/$line"
+
+ if [[ $kernel != */vmlinuz ]]; then
# triggers when it's a change to usr/lib/initcpio/*, usr/lib/systemd/boot/efi/linuxx64.efi.stub or boot/*-ucode.img
if [[ $ACTION == "install" ]]; then
ALL=1
@@ -98,12 +100,12 @@ else
continue
fi
- if ! read -r pkgbase > /dev/null 2>&1 < "${line%/vmlinuz}/pkgbase"; then
+ if ! read -r pkgbase > /dev/null 2>&1 < "${kernel%/vmlinuz}/pkgbase"; then
# if the kernel has no pkgbase, we skip it
continue
fi
- KERNELS+=("$line")
+ KERNELS+=("$kernel")
done
fi