summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Fauchon2021-01-08 17:03:13 +0800
committerPaul Fauchon2021-01-08 17:03:13 +0800
commita7abce27b7193a45675d5586c7523d5134341b5b (patch)
tree449953ece347104b31309170c48a0f75be980aca
downloadaur-a7abce27b7193a45675d5586c7523d5134341b5b.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e4832d581ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = unifi-throughput-ncurses
+ pkgdesc = Display unifi controller throughput in a terminal
+ pkgver = r57.b7c113f
+ pkgrel = 1
+ url = https://github.com/lamarios/unifi-throughput-ncurses/
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = go
+ depends = ncurses
+ source = git://github.com/lamarios/unifi-throughput-ncurses/
+ sha512sums = SKIP
+
+pkgname = unifi-throughput-ncurses
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fa343555708
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Paul Fauchon <p.fauchon at gmail dot com>
+pkgname=unifi-throughput-ncurses
+pkgver=r57.b7c113f
+pkgrel=1
+pkgdesc="Display unifi controller throughput in a terminal"
+arch=('x86_64')
+url="https://github.com/lamarios/unifi-throughput-ncurses/"
+license=('MIT')
+depends=('ncurses')
+makedepends=('git' 'go')
+
+source=("git://github.com/lamarios/unifi-throughput-ncurses/")
+
+sha512sums=('SKIP')
+
+pkgver() {
+ cd unifi-throughput-ncurses
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd unifi-throughput-ncurses
+ make
+ mkdir -p $pkgdir/usr/bin
+ cp unifi-throughput $pkgdir/usr/bin/unifi-throughput
+}
+