summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraudiolinux2016-06-01 17:32:49 +0200
committeraudiolinux2016-06-01 17:32:49 +0200
commit6b4381e3c331cfca24914a31dd0ec8413ca9c47d (patch)
tree398bfcbf750850ae169d1e3813299ce0844827a2
parent877ee9e4d80c6894e1407ba8fe868c0f857257d4 (diff)
downloadaur-6b4381e3c331cfca24914a31dd0ec8413ca9c47d.tar.gz
Added user systemd service
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--unified-remote-server.install9
-rw-r--r--urserver.service6
4 files changed, 17 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 554e2213d8e4..5d8d79e9ac6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Mar 26 19:04:14 UTC 2016
+# Wed Jun 1 15:32:17 UTC 2016
pkgbase = unified-remote-server
pkgdesc = Unified Remote Server
pkgver = 3.3.5.738
- pkgrel = 1
+ pkgrel = 2
url = http://www.unifiedremote.com/
install = unified-remote-server.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 33f2bd9fe403..dfb60d7d6d87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=unified-remote-server
pkgver=3.3.5.738
-pkgrel=1
+pkgrel=2
pkgdesc="Unified Remote Server"
arch=('x86_64')
url="http://www.unifiedremote.com/"
@@ -35,6 +35,6 @@ package() {
chmod 755 "${pkgdir}/opt/urserver/urserver-stop"
# add systemd service
- install -Dm644 "urserver.service" "$pkgdir/usr/lib/systemd/system/urserver.service"
+ install -Dm644 "urserver.service" "$pkgdir/usr/lib/systemd/user/urserver.service"
}
diff --git a/unified-remote-server.install b/unified-remote-server.install
index b95a1284607c..6d13b6de3777 100644
--- a/unified-remote-server.install
+++ b/unified-remote-server.install
@@ -6,6 +6,15 @@ echo "
add the above line to a startup script etc.
+ There is also a user systemd serice available.
+ You can start it with
+ systemctl --user start urserver
+ You can enable at boot with
+ systemctl --user enable urserver
+ (Note: A one time call (as user) to
+ /opt/urserver/urserver-start
+ could be necessary before using it)
+
For more options:
/opt/urserver/urserver --help
diff --git a/urserver.service b/urserver.service
index 7fc620280b0c..ac2fef9f61db 100644
--- a/urserver.service
+++ b/urserver.service
@@ -3,9 +3,11 @@ Description=Unified Remote Server
After=network.target
[Service]
+Type=oneshot
RemainAfterExit=yes
-ExecStart=/bin/bash /opt/urserver/urserver-start
+ExecStart=/bin/bash /opt/urserver/urserver-start --no-manager --no-copy
ExecStop=/bin/bash /opt/urserver/urserver-stop
[Install]
-WantedBy=network.target
+WantedBy=default.target
+