summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneeshy2022-08-07 01:51:53 -0400
committerneeshy2022-08-07 01:51:53 -0400
commit4356fd10745a779fee9aa82a3b9959f53e8f0305 (patch)
tree1573ac1262d3bcc6e3f0b6d0b3dfe5ac0ee9f257
parenta9547dab782c6ccab84bcc3dafeeb60507b3524a (diff)
downloadaur-4356fd10745a779fee9aa82a3b9959f53e8f0305.tar.gz
unifont: fix build for users of MAKEFLAGS="-j4"
by moving the compilation step into build()
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 143a62402fd6..ba96b695c7aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,6 +16,11 @@ sha256sums=('1f5e517ccf4cb3a09cffe31ac52de70d8f076fe024a4a2453e07db57bb64febb'
'SKIP')
validpgpkeys=('95D2E9AB8740D8046387FD151A09227B1F435A33') # Paul Hardy <unifoundry@unifoundry.com>
+build() {
+ cd "$srcdir/unifont-$pkgver/src"
+ make
+}
+
package_pcf-unifont() {
pkgdesc="A free bitmap font with wide Unicode support (PCF version)"
@@ -47,7 +52,6 @@ package_unifont-utils() {
)
cd "$srcdir/unifont-$pkgver"
- mkdir -p bin
- make -C src all install PREFIX="$pkgdir/usr" LOCALBINDIR=../bin
+ make -C src install PREFIX="$pkgdir/usr" LOCALBINDIR=../bin
make -C man install PREFIX="$pkgdir/usr" COMPRESS=1
}