summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2023-07-24 16:48:38 +0200
committerMarcell Meszaros2023-07-24 17:38:36 +0200
commit29ed14f28060908d026f154f843f589182ad33ed (patch)
treece0044a1d8b9d606b7df9048ae86b266d97f946f
parentbdbb55486a587ba1cc8adabb33c8db3de73c6bb1 (diff)
downloadaur-29ed14f28060908d026f154f843f589182ad33ed.tar.gz
1.1-2: adjust deps, remove unneded install scripts and runpaths
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD38
2 files changed, 53 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 558478cf0ea6..c574c0be14fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,31 @@
pkgbase = unigine-superposition
pkgdesc = Interactive Unigine Benchmark: walk through a lab of a lone professor
pkgver = 1.1
- pkgrel = 1
+ pkgrel = 2
url = https://benchmark.unigine.com/superposition
arch = x86_64
license = custom:UNIGINE Engine
- depends = libgl
+ makedepends = patchelf
+ depends = dbus
+ depends = fontconfig
+ depends = freetype2
depends = gcc-libs
- depends = libxrandr
+ depends = glib2
+ depends = hicolor-icon-theme
+ depends = libgl
+ depends = libice
+ depends = libsm
+ depends = libxcb
+ depends = libxext
+ depends = libxi
depends = libxinerama
- depends = fontconfig
- depends = qt5-declarative
- depends = libxkbcommon-x11
+ depends = libxrandr
+ depends = libxrender
+ depends = libx11
+ depends = openal
+ depends = qt5-base
+ depends = sh
+ depends = zlib
options = !strip
source = https://assets.unigine.com/d/Unigine_Superposition-1.1.run
source = Superposition.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 8b5971252930..f8ff10023efd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,34 @@
pkgname=unigine-superposition
_pkgname=Unigine_Superposition
pkgver=1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Interactive Unigine Benchmark: walk through a lab of a lone professor"
arch=('x86_64')
url="https://benchmark.unigine.com/superposition"
license=('custom:UNIGINE Engine')
-depends=('libgl' 'gcc-libs' 'libxrandr' 'libxinerama' 'fontconfig' 'qt5-declarative' 'libxkbcommon-x11')
+depends=(
+ 'dbus'
+ 'fontconfig'
+ 'freetype2'
+ 'gcc-libs'
+ 'glib2'
+ 'hicolor-icon-theme'
+ 'libgl'
+ 'libice'
+ 'libsm'
+ 'libxcb'
+ 'libxext'
+ 'libxi'
+ 'libxinerama'
+ 'libxrandr'
+ 'libxrender'
+ 'libx11'
+ 'openal'
+ 'qt5-base'
+ 'sh'
+ 'zlib'
+)
+makedepends=('patchelf')
options=("!strip")
source=("https://assets.unigine.com/d/${_pkgname}-${pkgver}.run" "Superposition.desktop")
b2sums=('f0447b0ccd860e653c2308637c93ed29ec851ff9923251edbd37a14b021149038f1c252deb0f3c4954fd4508883b1a2994a87b34a5e18902cef6c82c6ccc6b6b'
@@ -31,13 +53,19 @@ package() {
cat >> "${pkgdir}/usr/bin/unigine-superposition" << \here
#!/bin/sh
cd /opt/unigine-superposition/bin
-./launcher
+LD_LIBRARY_PATH='/opt/unigine-superposition/bin:/opt/unigine-superposition/bin/qt/lib' ./launcher
here
chmod a+x "${pkgdir}/usr/bin/unigine-superposition"
# fix openssl1.0 stuff
- mv "${pkgdir}/opt/unigine-superposition/bin/qt/lib/libcrypto.so"{,.1.0.0}
+ mv -v "${pkgdir}/opt/unigine-superposition/bin/qt/lib/libcrypto.so"{,.1.0.0}
find "${pkgdir}/opt/unigine-superposition/bin/qt" -name "*.so*" -exec chmod a+x {} \;
- ln -s /opt/unigine-superposition/bin/qt/lib/libcrypto.so.1.0.0 "${pkgdir}/opt/unigine-superposition/bin/qt/lib/libcrypto.so"
+ ln -sv /opt/unigine-superposition/bin/qt/lib/libcrypto.so.1.0.0 "${pkgdir}/opt/unigine-superposition/bin/qt/lib/libcrypto.so"
+ # remove unneeded install scripts
+ rm -v "${pkgdir}/opt/unigine-superposition/"*install.sh
+ # removing unneded libraries
+ rm -v "${pkgdir}/opt/unigine-superposition/bin/libopenal.so"
+ # removing runpaths
+ patchelf --remove-rpath "${pkgdir}/opt/unigine-superposition/bin/launcher"
# misc
install -Dm644 docs/Superposition_Benchmark_End-User_License_Agreement.pdf "${pkgdir}"/usr/share/licenses/${pkgname}/license
install -Dm644 docs/Superposition_Benchmark_User_Manual.pdf "${pkgdir}"/usr/share/doc/${pkgname}/User_Manual.pdf