summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorG. Schlisio2017-04-13 01:03:47 +0200
committerG. Schlisio2017-04-13 01:03:47 +0200
commit60926d01a7261e3aaa3a4776b1cf16224deb77d7 (patch)
tree08692571b675dc7e5459179067d1b0676999a9f9
parentc2f355d839d4103a279f567ef2c676144cb47775 (diff)
downloadaur-60926d01a7261e3aaa3a4776b1cf16224deb77d7.tar.gz
some fixes
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD24
2 files changed, 13 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41a200b61acf..5a8aa3156dae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = unigine-superposition
pkgdesc = Interactive Unigine Benchmark: walk through a lab of a lone professor
pkgver = 1.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.unigine.com
- arch = i686
arch = x86_64
license = custom:UNIGINE Engine
depends = libgl
@@ -11,6 +10,8 @@ pkgbase = unigine-superposition
depends = libxrandr
depends = libxinerama
depends = fontconfig
+ depends = qt5-declarative
+ depends = libxkbcommon-x11
optdepends = openal: sound support
source = https://assets.unigine.com/d/Unigine_Superposition-1.0.run
sha512sums = 1aa51b04381bedb0d3519f1ef90dcc77607b04b124ea3577dcc38eb8e609e5e8c2d21de4b4b19ca5d92542856d152fcec88d19d5b86fca307aa8f7e84f5b28b1
diff --git a/PKGBUILD b/PKGBUILD
index 3e027912729c..21cc215c3971 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,31 +3,27 @@
pkgname=unigine-superposition
_pkgname=Unigine_Superposition
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Interactive Unigine Benchmark: walk through a lab of a lone professor"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.unigine.com"
license=('custom:UNIGINE Engine')
-depends=('libgl' 'gcc-libs' 'libxrandr' 'libxinerama' 'fontconfig')
+depends=('libgl' 'gcc-libs' 'libxrandr' 'libxinerama' 'fontconfig' 'qt5-declarative' 'libxkbcommon-x11')
optdepends=('openal: sound support')
source=("https://assets.unigine.com/d/"${_pkgname}"-"${pkgver}".run")
sha512sums=('1aa51b04381bedb0d3519f1ef90dcc77607b04b124ea3577dcc38eb8e609e5e8c2d21de4b4b19ca5d92542856d152fcec88d19d5b86fca307aa8f7e84f5b28b1')
PKGEXT=.pkg.tar
-[ "${CARCH}" = "i686" ] && _arch=x86
-[ "${CARCH}" = "x86_64" ] && _arch=x64
-
build() {
sh "${_pkgname}"-"${pkgver}".run --target "${pkgname}" --noexec
}
package() {
- cd "${srcdir}"/"${pkgname}"
- install -d "${pkgdir}"/opt/"${pkgname}"/bin/
- install -m775 bin/*_"${_arch}"* "${pkgdir}"/opt/"${pkgname}"/bin/
- cp -R data "${pkgdir}"/opt/"${pkgname}"/
- install -Dm755 Superposition "${pkgdir}"/usr/bin/"${pkgname}"
- sed -e "s|cd ./bin|cd /opt/"${pkgname}"/bin|" -e "s|./launcher_x86|./launcher_"${_arch}"|g" -i "${pkgdir}"/usr/bin/"${pkgname}"
- install -Dm644 docs/Superposition_Benchmark_End-User_License_Agreement.pdf "${pkgdir}"/usr/share/licenses/"${pkgname}"/license
- install -Dm644 docs/Superposition_Benchmark_User_Manual.pdf "${pkgdir}"/usr/share/doc/"${pkgname}"/User_Manual.pdf
+ cd "${srcdir}/${pkgname}"
+ install -d "${pkgdir}/opt/${pkgname}"
+ cp -R * "${pkgdir}/opt/${pkgname}"/
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/opt/${pkgname}/bin/launcher" "${pkgdir}/usr/bin/unigine-superposition"
+ install -Dm644 docs/Superposition_Benchmark_End-User_License_Agreement.pdf "${pkgdir}"/usr/share/licenses/${pkgname}/license
+ install -Dm644 docs/Superposition_Benchmark_User_Manual.pdf "${pkgdir}"/usr/share/doc/${pkgname}/User_Manual.pdf
}