summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorG. Schlisio2017-04-12 18:44:21 +0200
committerG. Schlisio2017-04-12 18:44:21 +0200
commitc2f355d839d4103a279f567ef2c676144cb47775 (patch)
tree77a397ea35c98b154b5d95c195c392156dad9f90
downloadaur-c2f355d839d4103a279f567ef2c676144cb47775.tar.gz
first version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41a200b61acf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = unigine-superposition
+ pkgdesc = Interactive Unigine Benchmark: walk through a lab of a lone professor
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.unigine.com
+ arch = i686
+ arch = x86_64
+ license = custom:UNIGINE Engine
+ depends = libgl
+ depends = gcc-libs
+ depends = libxrandr
+ depends = libxinerama
+ depends = fontconfig
+ optdepends = openal: sound support
+ source = https://assets.unigine.com/d/Unigine_Superposition-1.0.run
+ sha512sums = 1aa51b04381bedb0d3519f1ef90dcc77607b04b124ea3577dcc38eb8e609e5e8c2d21de4b4b19ca5d92542856d152fcec88d19d5b86fca307aa8f7e84f5b28b1
+
+pkgname = unigine-superposition
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e027912729c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# based on unigine-valley by ajs124 and meyithi
+
+pkgname=unigine-superposition
+_pkgname=Unigine_Superposition
+pkgver=1.0
+pkgrel=1
+pkgdesc="Interactive Unigine Benchmark: walk through a lab of a lone professor"
+arch=('i686' 'x86_64')
+url="http://www.unigine.com"
+license=('custom:UNIGINE Engine')
+depends=('libgl' 'gcc-libs' 'libxrandr' 'libxinerama' 'fontconfig')
+optdepends=('openal: sound support')
+source=("https://assets.unigine.com/d/"${_pkgname}"-"${pkgver}".run")
+sha512sums=('1aa51b04381bedb0d3519f1ef90dcc77607b04b124ea3577dcc38eb8e609e5e8c2d21de4b4b19ca5d92542856d152fcec88d19d5b86fca307aa8f7e84f5b28b1')
+PKGEXT=.pkg.tar
+
+[ "${CARCH}" = "i686" ] && _arch=x86
+[ "${CARCH}" = "x86_64" ] && _arch=x64
+
+build() {
+ sh "${_pkgname}"-"${pkgver}".run --target "${pkgname}" --noexec
+}
+
+package() {
+ cd "${srcdir}"/"${pkgname}"
+ install -d "${pkgdir}"/opt/"${pkgname}"/bin/
+ install -m775 bin/*_"${_arch}"* "${pkgdir}"/opt/"${pkgname}"/bin/
+ cp -R data "${pkgdir}"/opt/"${pkgname}"/
+ install -Dm755 Superposition "${pkgdir}"/usr/bin/"${pkgname}"
+ sed -e "s|cd ./bin|cd /opt/"${pkgname}"/bin|" -e "s|./launcher_x86|./launcher_"${_arch}"|g" -i "${pkgdir}"/usr/bin/"${pkgname}"
+ install -Dm644 docs/Superposition_Benchmark_End-User_License_Agreement.pdf "${pkgdir}"/usr/share/licenses/"${pkgname}"/license
+ install -Dm644 docs/Superposition_Benchmark_User_Manual.pdf "${pkgdir}"/usr/share/doc/"${pkgname}"/User_Manual.pdf
+}