summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgeorg2017-04-15 11:30:28 +0200
committergeorg2017-04-15 11:30:28 +0200
commitccdbff40f93aa625c1aefd5a8dad8746f3fb4682 (patch)
tree6513c5c886560856a3802af552fc1012b628996b
parent60926d01a7261e3aaa3a4776b1cf16224deb77d7 (diff)
downloadaur-ccdbff40f93aa625c1aefd5a8dad8746f3fb4682.tar.gz
refined: desktop file, appropriate starter, icons, !strip - we're getting somewhere
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD40
-rw-r--r--Superposition.desktop9
3 files changed, 44 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a8aa3156dae..5a818bc70866 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sat Apr 15 09:29:26 UTC 2017
pkgbase = unigine-superposition
pkgdesc = Interactive Unigine Benchmark: walk through a lab of a lone professor
pkgver = 1.0
- pkgrel = 2
+ pkgrel = 3
url = http://www.unigine.com
arch = x86_64
license = custom:UNIGINE Engine
@@ -13,8 +15,11 @@ pkgbase = unigine-superposition
depends = qt5-declarative
depends = libxkbcommon-x11
optdepends = openal: sound support
+ options = !strip
source = https://assets.unigine.com/d/Unigine_Superposition-1.0.run
+ source = Superposition.desktop
sha512sums = 1aa51b04381bedb0d3519f1ef90dcc77607b04b124ea3577dcc38eb8e609e5e8c2d21de4b4b19ca5d92542856d152fcec88d19d5b86fca307aa8f7e84f5b28b1
+ sha512sums = 7b37670e77088d05b639b9f6f67a6d88d0aafa8e67dfbe4ea23059c5a3422c58359f5d9642846eff3e0ce95253746997a95f8dcd8f44da13b5837618d5e1f000
pkgname = unigine-superposition
diff --git a/PKGBUILD b/PKGBUILD
index 21cc215c3971..84006559fdf9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,27 +3,45 @@
pkgname=unigine-superposition
_pkgname=Unigine_Superposition
pkgver=1.0
-pkgrel=2
+pkgrel=3
pkgdesc="Interactive Unigine Benchmark: walk through a lab of a lone professor"
arch=('x86_64')
url="http://www.unigine.com"
license=('custom:UNIGINE Engine')
depends=('libgl' 'gcc-libs' 'libxrandr' 'libxinerama' 'fontconfig' 'qt5-declarative' 'libxkbcommon-x11')
optdepends=('openal: sound support')
-source=("https://assets.unigine.com/d/"${_pkgname}"-"${pkgver}".run")
-sha512sums=('1aa51b04381bedb0d3519f1ef90dcc77607b04b124ea3577dcc38eb8e609e5e8c2d21de4b4b19ca5d92542856d152fcec88d19d5b86fca307aa8f7e84f5b28b1')
+options=("!strip")
+source=("https://assets.unigine.com/d/${_pkgname}-${pkgver}.run" "Superposition.desktop")
+sha512sums=('1aa51b04381bedb0d3519f1ef90dcc77607b04b124ea3577dcc38eb8e609e5e8c2d21de4b4b19ca5d92542856d152fcec88d19d5b86fca307aa8f7e84f5b28b1'
+ '7b37670e77088d05b639b9f6f67a6d88d0aafa8e67dfbe4ea23059c5a3422c58359f5d9642846eff3e0ce95253746997a95f8dcd8f44da13b5837618d5e1f000')
PKGEXT=.pkg.tar
build() {
- sh "${_pkgname}"-"${pkgver}".run --target "${pkgname}" --noexec
+ sh ${_pkgname}-${pkgver}.run --target ${pkgname} --noexec
}
package() {
- cd "${srcdir}/${pkgname}"
- install -d "${pkgdir}/opt/${pkgname}"
- cp -R * "${pkgdir}/opt/${pkgname}"/
- install -d "${pkgdir}/usr/bin"
- ln -s "/opt/${pkgname}/bin/launcher" "${pkgdir}/usr/bin/unigine-superposition"
- install -Dm644 docs/Superposition_Benchmark_End-User_License_Agreement.pdf "${pkgdir}"/usr/share/licenses/${pkgname}/license
- install -Dm644 docs/Superposition_Benchmark_User_Manual.pdf "${pkgdir}"/usr/share/doc/${pkgname}/User_Manual.pdf
+ cd "${srcdir}/${pkgname}"
+ # bulk data
+ install -d "${pkgdir}/opt/${pkgname}"
+ cp -R * "${pkgdir}/opt/${pkgname}"/
+ # launcher
+ install -d "${pkgdir}/usr/bin"
+ cat >> "${pkgdir}/usr/bin/unigine-superposition" << \here
+#!/bin/sh
+cd /opt/${pkgname}/bin
+launcher
+here
+ chmod a+x "${pkgdir}/usr/bin/unigine-superposition"
+ # misc
+ install -Dm644 docs/Superposition_Benchmark_End-User_License_Agreement.pdf "${pkgdir}"/usr/share/licenses/${pkgname}/license
+ install -Dm644 docs/Superposition_Benchmark_User_Manual.pdf "${pkgdir}"/usr/share/doc/${pkgname}/User_Manual.pdf
+ install -Dm644 ../Superposition.desktop "${pkgdir}/usr/share/applications/Superposition.desktop"
+ # icons
+ for RES in 16 24 32 48 64 128 256
+ do
+ convert -resize ${RES}x${RES} Superposition.png Superposition_${RES}.png
+ install -Dm644 Superposition_${RES}.png "${pkgdir}/usr/share/icons/hicolor/${RES}x${RES}/apps/Superposition_${RES}.png"
+
+ done
}
diff --git a/Superposition.desktop b/Superposition.desktop
new file mode 100644
index 000000000000..27e4d17492d4
--- /dev/null
+++ b/Superposition.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Exec=/opt/unigine-superposition/bin/launcher
+Path=/opt/unigine-superposition/bin
+Name=Superposition Benchmark
+GenericName=A GPU Stress test tool from the UNIGINE Corp.
+Icon=Superposition
+Terminal=false
+Categories=Launcher;Benchmark;