summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCan Celasun2015-05-31 21:46:22 +0300
committerCan Celasun2015-05-31 21:46:22 +0300
commit0e180133d2fae2d15e8093ae1ad1362b39723b70 (patch)
treeac0a7ddfde4afb1fc56d0a4531d9369001b9e8e9
downloadaur-0e180133d2fae2d15e8093ae1ad1362b39723b70.tar.gz
New structure
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE5
-rw-r--r--PKGBUILD42
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d85484f3edd4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = unigine-tropics
+ pkgdesc = Demonstration and benchmarking of the Unigine 3D engine
+ pkgver = 1.3
+ pkgrel = 2
+ url = http://unigine.com/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = lib32-libstdc++5
+ depends = lib32-libxrandr
+ depends = lib32-libgl
+ depends = lib32-openal
+ depends = lib32-libxinerama
+ source = http://mirror74.ddns.school-adm.ru/Soft/Info-Test/Unigine_benchmarks/Unigine_Tropics-1.3.run
+ source = LICENSE
+ md5sums = 73729f5ccde2bcf991ecff10feb6dbdf
+ md5sums = 322eea429002108ec286be641c5b9549
+
+pkgname = unigine-tropics
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..b7d306aa462d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,5 @@
+Unigine v0.33 binary license agreement:
+http://unigine.com/products/unigine_v0.33/binary_license/
+
+Unigine v0.33 source license agreement:
+http://unigine.com/products/unigine_v0.33/source_license/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a72f5edec734
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer Can Celasun <dcelasun[at]gmail[dot]com>
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: Mathias Burén (fackamato) <mathias.buren@gmail.com>
+
+pkgname=unigine-tropics
+_pkgname=Unigine_Tropics
+pkgver=1.3
+pkgrel=2
+pkgdesc="Demonstration and benchmarking of the Unigine 3D engine"
+arch=('i686' 'x86_64')
+url="http://unigine.com/"
+license=('custom')
+md5sums=('73729f5ccde2bcf991ecff10feb6dbdf'
+ '322eea429002108ec286be641c5b9549')
+[ `uname -m` = 'i686' ] &&
+ depends=('libstdc++5' 'libxrandr' 'libgl' 'openal' 'libxinerama')
+[ `uname -m` = 'x86_64' ] &&
+ depends=('lib32-libstdc++5' 'lib32-libxrandr' 'lib32-libgl' 'lib32-openal' 'lib32-libxinerama')
+source=(http://mirror74.ddns.school-adm.ru/Soft/Info-Test/Unigine_benchmarks/${_pkgname}-${pkgver}.run \
+ LICENSE)
+
+build() {
+ cd "$srcdir"
+ sh ${_pkgname}-$pkgver.run
+}
+
+package() {
+ cd "$srcdir"
+ install -m755 -d $pkgdir/opt/$pkgname
+ cp -r tropics/* $pkgdir/opt/$pkgname/
+
+ for _file in $pkgdir/opt/$pkgname/*.sh; do
+ sed -i "s_\./bin_/opt/$pkgname/bin_" $_file
+ install -m755 -D $_file $pkgdir/usr/bin/${pkgname}_${_file/*\//}
+ rm -f $_file
+ done
+
+ find $pkgdir/opt/$pkgname -type d -exec chmod 755 {} +
+ find $pkgdir/opt/$pkgname -type f -exec chmod 644 {} +
+ find $pkgdir/opt/$pkgname -name Tropics -exec chmod 755 {} +
+ install -m644 -D LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}