summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrhun Parmaksız2023-08-25 12:41:32 +0300
committerOrhun Parmaksız2023-08-25 12:41:32 +0300
commit66b688cc5d65ab6ec7103e8ae9529f19337d1ff5 (patch)
tree39a4c8fb2f1b5bebeba8b5ed54eab7caebaff0c8
parentd5eb5fd6725896acb66ee50ae33802216df8f998 (diff)
downloadaur-unimap-git.tar.gz
upgpkg: unimap-git 0.6.0.r0.g3afaf47-1
upstream release
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efffd8d7035a..1feb4a2846de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = unimap-git
pkgdesc = Scan only once by IP address and reduce scan times with Nmap for large amounts of data (git)
- pkgver = 0.5.1.r1.g89e3004
+ pkgver = 0.6.0.r0.g3afaf47
pkgrel = 1
url = https://github.com/Edu4rdSHL/unimap
arch = x86_64
license = GPL3
- makedepends = rust
+ makedepends = cargo
makedepends = git
depends = nmap
provides = unimap
diff --git a/PKGBUILD b/PKGBUILD
index 9f6f7cad2ee0..f05b426345e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
# https://github.com/orhun/pkgbuilds
pkgname=unimap-git
-pkgver=0.5.1.r1.g89e3004
+pkgver=0.6.0.r0.g3afaf47
pkgrel=1
pkgdesc="Scan only once by IP address and reduce scan times with Nmap for large amounts of data (git)"
arch=('x86_64')
url="https://github.com/Edu4rdSHL/unimap"
license=('GPL3')
depends=('nmap')
-makedepends=('rust' 'git')
+makedepends=('cargo' 'git')
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
source=("git+${url}")
@@ -21,14 +21,19 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "${pkgname%-git}"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
build() {
cd "${pkgname%-git}"
- cargo build --release --locked
+ cargo build --release --frozen
}
check() {
cd "${pkgname%-git}"
- cargo test --release --locked
+ cargo test --frozen
}
package() {