summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-10-15 18:00:22 +0300
committerorhun2020-10-15 18:00:22 +0300
commitf4f3d68221b8ac5013744ce30d9632d8ee5194dc (patch)
tree47cd3f950157b55c7793d9a1ab59ced5c5ad7e59
downloadaur-f4f3d68221b8ac5013744ce30d9632d8ee5194dc.tar.gz
Initial upload: unimap-git 0.2.0.r0.g48cb688-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57e404d09e5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = unimap-git
+ pkgdesc = Scan only once by IP address and reduce scan times with Nmap for large amounts of data (git)
+ pkgver = 0.2.0.r0.g48cb688
+ pkgrel = 1
+ url = https://github.com/Edu4rdSHL/unimap
+ arch = x86_64
+ license = GPL3
+ makedepends = cargo
+ makedepends = git
+ depends = nmap
+ provides = unimap
+ conflicts = unimap
+ source = git+https://github.com/Edu4rdSHL/unimap
+ sha512sums = SKIP
+
+pkgname = unimap-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f706cda7d896
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# Maintainer: Edu4rdSHL <edu4rdshl@securityhacklabs.net>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=unimap-git
+pkgver=0.2.0.r0.g48cb688
+pkgrel=1
+pkgdesc="Scan only once by IP address and reduce scan times with Nmap for large amounts of data (git)"
+arch=('x86_64')
+url="https://github.com/Edu4rdSHL/unimap"
+license=('GPL3')
+depends=('nmap')
+makedepends=('cargo' 'git')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
+source=("git+${url}")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname%-git}"
+ cargo build --release --locked --all-features
+}
+
+check() {
+ cd "${pkgname%-git}"
+ cargo test --release --locked
+}
+
+package() {
+ cd "${pkgname%-git}"
+ install -Dm 755 "target/release/${pkgname%-git}" -t "${pkgdir}/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/${pkgname%-git}"
+}