summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorroot2021-03-14 13:39:16 +0100
committerroot2021-03-14 13:39:16 +0100
commit2f2d37e97f51b0f0a88749636b7d4b73caa620c6 (patch)
tree58e8469614fa134c2c150e7ee5d73a6647bdcbc6
downloadaur-2f2d37e97f51b0f0a88749636b7d4b73caa620c6.tar.gz
Initial Commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD53
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7484e3066fd5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = unison-gtk-2.48.4-compat-bin
+ pkgdesc = GTK2-GUI for unison. Specific version ${_pkgver}, compatible with parallel installation to other versions of unison binaries (but pay attention to the local user configurations!). Prebuilt binary from debian, repackaged.
+ pkgver = 2.48.4
+ pkgrel = 1
+ url = http://www.cis.upenn.edu/~bcpierce/unison/
+ arch = x86_64
+ license = GPL2
+ depends = unison-2.48.4
+ depends = gtk2
+ provides = unison-gtk-2.48.4=2.48.4
+ provides = unison-gtk-2.48=2.48.4
+ conflicts = unison-gtk-2.48
+ source = http://ftp.de.debian.org/debian/pool/main/u/unison/unison-gtk_2.48.4-1+b1_amd64.deb
+ sha256sums = 54ab2d5a7595ef82950f2c3228adc98e022690fb0ba25102d479da46124f32ce
+
+pkgname = unison-gtk-2.48.4-compat-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dece54dde480
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+#Maintainer: dreieck
+#Contributor: Gaetan Bisson <bisson@archlinux.org>
+#Contributor: Tobias Powalowski <tpowa@archlinux.org>
+
+_pkgname=unison-gtk
+_pkgver=2.48.4
+_debianver="-1+b1"
+pkgname="${_pkgname}-${_pkgver}-compat-bin"
+pkgver="${_pkgver}"
+pkgrel=1
+pkgdesc='GTK2-GUI for unison. Specific version ${_pkgver}, compatible with parallel installation to other versions of unison binaries (but pay attention to the local user configurations!). Prebuilt binary from debian, repackaged.'
+url='http://www.cis.upenn.edu/~bcpierce/unison/'
+arch=(
+ 'x86_64'
+)
+license=('GPL2')
+depends=(
+ ${_pkgname%-gtk}-${_pkgver}
+ "gtk2"
+)
+provides=(
+ "${_pkgname}-${_pkgver}=${pkgver}"
+ "${_pkgname}-${_pkgver%.*}=${pkgver}"
+)
+conflicts=(
+ "${_pkgname}-${pkgver%.*}"
+)
+source=(
+ "http://ftp.de.debian.org/debian/pool/main/u/${_pkgname%-gtk}/${_pkgname}_${_pkgver}${_debianver}_amd64.deb"
+)
+sha256sums=(
+ '54ab2d5a7595ef82950f2c3228adc98e022690fb0ba25102d479da46124f32ce'
+)
+
+prepare() {
+ _content="data.tar.xz"
+ mkdir -p "${srcdir}/content"
+ cd "${srcdir}/content"
+ msg2 "Extracting ${_content} ..."
+ bsdtar xf "${srcdir}/${_content}"
+}
+
+package() {
+ cd "${srcdir}/content"
+
+ cp -a "${srcdir}/content"/* "${pkgdir}"/
+
+ rm -R "${pkgdir}/usr/bin/unison-latest-stable-gtk"
+ rm -R "${pkgdir}/usr/share/man/man1/unison-latest-stable-gtk.1.gz"
+
+ cd "${pkgdir}"/usr/bin
+ ln -s "unison-${_pkgver}-gtk" "unison-${_pkgver}-x11"
+}