summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralecksandr2023-05-06 11:39:11 -0600
committeralecksandr2023-05-06 11:39:11 -0600
commitadff0228b98bb6ff470369ce2343ad5fd7f600c8 (patch)
treeb9445266eb624678c606999d535684dc8eaec9ae
downloadaur-adff0228b98bb6ff470369ce2343ad5fd7f600c8.tar.gz
Initial release v1.0.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a702ecdf845
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = unittest-c
+ pkgdesc = unittest c is a fast and simple macro-based unit testing framework for C. It's inspired by the Python unittest module and designed to reduce boilerplate code. With macros and a built-in test runner, it's ideal for large test suites.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/alecksandr26/unittest-c
+ arch = x86_64
+ license = MIT License
+ makedepends = gcc
+ makedepends = git
+ makedepends = make
+ makedepends = binutils
+ makedepends = coreutils
+ makedepends = c-exceptions
+ optdepends = valgrind
+ source = git+https://github.com/alecksandr26/unittest-c
+ md5sums = SKIP
+
+pkgname = unittest-c
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed02b541f869
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# @file PKGBUILD
+# @brief The package script
+# @author Erick Carrillo.
+# @copyright Copyright (C) 2023, Erick Alejandro Carrillo López, All right reserved.
+# @license This project is released under the MIT License
+
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: alecksandr <sansepiol26@gmail.com>
+pkgname=unittest-c
+pkgver=1.0.0
+pkgrel=1
+epoch=
+pkgdesc="unittest c is a fast and simple macro-based unit testing framework for C.
+It's inspired by the Python unittest module and designed to reduce boilerplate code.
+With macros and a built-in test runner, it's ideal for large test suites."
+arch=(x86_64)
+url="https://github.com/alecksandr26/unittest-c"
+license=('MIT License')
+depends=()
+makedepends=(gcc git make binutils coreutils c-exceptions)
+optdepends=(valgrind)
+source=("git+$url")
+md5sums=('SKIP')
+
+# Compile the source code
+build () {
+ cd $pkgname/
+ make compile
+}
+
+# Set the compiled files to create the package
+# in this specific order to be able to be installed
+package() {
+ cd $pkgdir
+ mkdir -p usr
+ mkdir -p usr/lib
+ cp -r ../../src/$pkgname/lib usr/
+ cp -r ../../src/$pkgname/include usr/
+}