summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2017-08-13 10:37:16 +0300
committerOscar Morante2017-08-13 10:37:16 +0300
commitd24c9ab871c70f20410b4b90f47b66d7d63a2e43 (patch)
tree0b84e06a1edef29d6d0e49b18bd7a60d7e6633d9
parent71d662ef4d6d0cf27f3ad0176b1289c68882c653 (diff)
downloadaur-d24c9ab871c70f20410b4b90f47b66d7d63a2e43.tar.gz
make monodevelop an optional dependency/split package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD56
2 files changed, 38 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 311d8e055898..57b0d2bc8deb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Jul 14 05:29:58 UTC 2017
+# Sun Aug 13 07:35:17 UTC 2017
pkgbase = unity-editor
pkgdesc = The world's most popular development platform for creating 2D and 3D multiplatform games and interactive experiences.
pkgver = 2017.1.0f3+20170711
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = https://unity3d.com/
arch = x86_64
@@ -17,7 +17,6 @@ pkgbase = unity-editor
depends = libpng12
depends = libxtst
depends = libpqxx
- depends = monodevelop
depends = npm
optdepends = ffmpeg: for WebGL exporting
optdepends = nodejs: for WebGL exporting
@@ -26,6 +25,7 @@ pkgbase = unity-editor
optdepends = java-environment: for Android and Tizen exporting
optdepends = android-sdk: for Android Remote
optdepends = android-udev: for Android Remote
+ optdepends = monodevelop-unity: for old MonoDevelop + Unity-specific addins
conflicts = unity3d
replaces = unity3d
noextract = unity-editor-installer-2017.1.0xf3Linux.sh
@@ -40,11 +40,13 @@ pkgbase = unity-editor
sha1sums = c3727d6851a3ffd0aef9b380e2485eed9f02ef6b
sha1sums = 8ffbfd8f4577b146d25217720ac6689c5d929e84
sha1sums = d1ecf758c9816f964febf601d065b0354940d866
- sha512sums = edcd35eaa416cee67017bcf6634066f13d8981519c975de810eeeb98587107794a0fe8d98fb7e05e80f3ab5279b545d27b1ae81ef84d542b4a8663a1d5abd0ac
- sha512sums = 9349fd1bf385d0cec8ed4596502b082c8f1f09c2c30a63d2f1d3b5e0695f86760ac7289eacc07d92d6f161ddd9ba838fb41883247fc5c8616e8bfe73f7eca070
- sha512sums = ef907b215996354dd4f76cae79687952e11937510823ec836bc984180803b5deb3fd5a055092e258ca3a2293b90ce0da7f0c8cdb7862d546d843e092b3dbc3a0
- sha512sums = 26946ad2c759699763c1284a1f30380072da2911659992fa2471b436df1f0535b6eef61007f11c2e010e4a002663324e42ef5ae1417aa45e0ec99f4e3f0aafb7
- sha512sums = 44676f54d83357721bee844d1e0e997e584b2148c871dbf24385976dda840f37e4cf4a1796fa17dec90fac539bac58e0e47fa0af0abc98e4cf795f735b23c1b0
pkgname = unity-editor
+pkgname = monodevelop-unity
+ pkgdesc = Unity's fork of MonoDevelop.
+ depends = monodevelop
+ optdepends = gnome-sharp
+ optdepends = referenceassemblies-2.0-bin
+ optdepends = referenceassemblies-3.5-bin
+
diff --git a/PKGBUILD b/PKGBUILD
index 9767fc89ff8e..11c2c45cd39e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,15 @@
# Maintainer: Oscar Morante <spacepluk at gmail dot com>
# Contributor: Ace <a.mad.coder at gmail dot com>
-pkgname=unity-editor
_version=2017.1.0
_build=f3
_buildtag=20170711
_randomstring=061bcf22327f
+_extractiondir=unity-editor-${_version}x${_build}Linux
+
+pkgname=('unity-editor' 'monodevelop-unity')
pkgver=${_version}${_build}+${_buildtag}
-pkgrel=2
+pkgrel=3
epoch=1
pkgdesc="The world's most popular development platform for creating 2D and 3D multiplatform games and interactive experiences."
arch=('x86_64')
@@ -25,7 +27,6 @@ depends=('desktop-file-utils'
'libpng12'
'libxtst'
'libpqxx'
- 'monodevelop'
'npm')
optdepends=('ffmpeg: for WebGL exporting'
'nodejs: for WebGL exporting'
@@ -33,7 +34,8 @@ optdepends=('ffmpeg: for WebGL exporting'
'gzip: for WebGL exporting'
'java-environment: for Android and Tizen exporting'
'android-sdk: for Android Remote'
- 'android-udev: for Android Remote')
+ 'android-udev: for Android Remote'
+ 'monodevelop-unity: for old MonoDevelop + Unity-specific addins')
conflicts=('unity3d')
replaces=('unity3d')
source=("http://beta.unity3d.com/download/${_randomstring}/unity-editor-installer-${_version}x${_build}Linux.sh"
@@ -47,11 +49,6 @@ sha1sums=('a494c8191738ed0cf2b2024d93b7154af2fefea6'
'c3727d6851a3ffd0aef9b380e2485eed9f02ef6b'
'8ffbfd8f4577b146d25217720ac6689c5d929e84'
'd1ecf758c9816f964febf601d065b0354940d866')
-sha512sums=('edcd35eaa416cee67017bcf6634066f13d8981519c975de810eeeb98587107794a0fe8d98fb7e05e80f3ab5279b545d27b1ae81ef84d542b4a8663a1d5abd0ac'
- '9349fd1bf385d0cec8ed4596502b082c8f1f09c2c30a63d2f1d3b5e0695f86760ac7289eacc07d92d6f161ddd9ba838fb41883247fc5c8616e8bfe73f7eca070'
- 'ef907b215996354dd4f76cae79687952e11937510823ec836bc984180803b5deb3fd5a055092e258ca3a2293b90ce0da7f0c8cdb7862d546d843e092b3dbc3a0'
- '26946ad2c759699763c1284a1f30380072da2911659992fa2471b436df1f0535b6eef61007f11c2e010e4a002663324e42ef5ae1417aa45e0ec99f4e3f0aafb7'
- '44676f54d83357721bee844d1e0e997e584b2148c871dbf24385976dda840f37e4cf4a1796fa17dec90fac539bac58e0e47fa0af0abc98e4cf795f735b23c1b0')
options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
@@ -69,36 +66,39 @@ build() {
rm $noextract
}
-package() {
- local extraction_dir="${srcdir}/unity-editor-${_version}x${_build}Linux"
-
- mkdir -p "${pkgdir}/opt/"
- mv ${extraction_dir} ${pkgdir}/opt/Unity
+package_unity-editor() {
+ mkdir -p "${pkgdir}/opt/Unity"
+ mv ${srcdir}/${_extractiondir}/Editor ${pkgdir}/opt/Unity/Editor
# HACK: fixes WebGL builds by adding a symlink (python -> python2) to the PATH
ln -s /usr/bin/python2 ${pkgdir}/opt/Unity/Editor/python
# Fix permissions
- chmod ga+rx ${pkgdir}/opt/Unity/Editor/Data/UnityExtensions/Unity/VR/*
- chmod ga+rx ${pkgdir}/opt/Unity/Editor/Data/UnityExtensions/Unity/VR/WindowsStoreApps/*
- chmod ga+rx ${pkgdir}/opt/Unity/Editor/Data/UnityExtensions/Unity/VR/HolographicSimulation/Rooms/
- chmod ga+rx ${pkgdir}/opt/Unity/Editor/Data/PlaybackEngines/WebGLSupport/BuildTools/Emscripten_Linux/node/
- chmod ga+rx ${pkgdir}/opt/Unity/Editor/Data/PlaybackEngines/WebGLSupport/BuildTools/Emscripten_Linux/node/0.10.18_64bit
- chmod ga+rx ${pkgdir}/opt/Unity/Editor/Data/PlaybackEngines/WebGLSupport/BuildTools/Emscripten_Linux/node/0.10.18_64bit/bin
+ find ${pkgdir}/opt/Unity/Editor/Data -type d -exec chmod ga+rx {} \;
# Use the launch scripts in the .desktop files
- sed -i "/^Exec=/c\Exec=/usr/bin/unity-editor" "${pkgdir}/opt/Unity/unity-editor.desktop"
- sed -i "/^Exec=/c\Exec=/usr/bin/monodevelop-unity" "${pkgdir}/opt/Unity/unity-monodevelop.desktop"
+ sed -i "/^Exec=/c\Exec=/usr/bin/unity-editor" "${srcdir}/${_extractiondir}/unity-editor.desktop"
- install -Dm644 -t "${pkgdir}/usr/share/applications" "${pkgdir}/opt/Unity/unity-editor.desktop" \
- "${pkgdir}/opt/Unity/unity-monodevelop.desktop"
+ install -Dm644 -t "${pkgdir}/usr/share/applications" "${srcdir}/${_extractiondir}/unity-editor.desktop"
+ install -Dm644 -t "${pkgdir}/usr/share/icons/hicolor/256x256/apps" "${srcdir}/${_extractiondir}/unity-editor-icon.png"
+ install -Dm755 -t "${pkgdir}/usr/bin" "${srcdir}/unity-editor"
+ install -Dm644 "${srcdir}/EULA" "${pkgdir}/usr/share/licenses/${pkgname}/EULA"
+}
- install -Dm644 -t "${pkgdir}/usr/share/icons/hicolor/256x256/apps" "${pkgdir}/opt/Unity/unity-editor-icon.png"
- install -Dm644 -t "${pkgdir}/usr/share/icons/hicolor/48x48/apps" "${srcdir}/unity-monodevelop.png"
+package_monodevelop-unity() {
+ pkgdesc="Unity's fork of MonoDevelop."
+ depends=('monodevelop')
+ optdepends=('gnome-sharp' 'referenceassemblies-2.0-bin' 'referenceassemblies-3.5-bin')
- install -Dm755 -t "${pkgdir}/usr/bin" "${srcdir}/unity-editor"
+ mkdir -p "${pkgdir}/opt/Unity"
+ mv ${srcdir}/${_extractiondir}/MonoDevelop ${pkgdir}/opt/Unity/MonoDevelop
+
+ # Use the launch scripts in the .desktop files
+ sed -i "/^Exec=/c\Exec=/usr/bin/monodevelop-unity" "${srcdir}/${_extractiondir}/unity-monodevelop.desktop"
+
+ install -Dm644 -t "${pkgdir}/usr/share/applications" "${srcdir}/${_extractiondir}/unity-monodevelop.desktop"
+ install -Dm644 -t "${pkgdir}/usr/share/icons/hicolor/48x48/apps" "${srcdir}/unity-monodevelop.png"
install -Dm755 -t "${pkgdir}/usr/bin" "${srcdir}/monodevelop-unity"
install -Dm644 "${srcdir}/EULA" "${pkgdir}/usr/share/licenses/${pkgname}/EULA"
}
-
# vim:set sw=2 sts=2 et: