summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2015-09-01 17:40:10 +0300
committerOscar Morante2015-09-01 17:40:10 +0300
commit30481cf2eb61a240c62c0c06f30e09f55f79e73a (patch)
treec4ff534f1d9ef47f7a51d84108127e2efec376e9
parent426c03edca4c9e24691ea6be359274559981e0fc (diff)
downloadaur-30481cf2eb61a240c62c0c06f30e09f55f79e73a.tar.gz
use the launch scripts in the .desktop files
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7d6c25f36d5..ccfaa3ba4d73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -60,6 +60,10 @@ package() {
# Remove bundled libresolv.so.2 for the time being (workarounds network problems)
rm "${pkgdir}/opt/Unity/Editor/Data/Tools/libresolv.so.2"
+ # Use the launch scripts in the .desktop files
+ sed -i "/^Exec=/c\Exec=/usr/bin/unity-editor" "${extraction_dir}/unity-editor.desktop"
+ sed -i "/^Exec=/c\Exec=/usr/bin/monodevelop-unity" "${extraction_dir}/unity-monodevelop.desktop"
+
install -Dm644 -t "${pkgdir}/usr/share/applications" "${extraction_dir}/unity-editor.desktop" \
"${extraction_dir}/unity-monodevelop.desktop"