summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2018-01-19 19:47:34 +0100
committerOscar Morante2018-01-19 19:47:34 +0100
commit591f75485bb1cb5050429ce8eef08e812aff1de2 (patch)
tree787e12259ead265d272b799bd65838dede5a2932
parent129459270b46e38e2ad57f9fbaf67baa71e21c07 (diff)
downloadaur-591f75485bb1cb5050429ce8eef08e812aff1de2.tar.gz
workaround bug in unity installer
There's a bug in the installer that tries to do GUI stuff when you use the contracted version of the parameters. Now it should work on chroots/headless systems.
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc8726a8f869..106e4bc23e72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -50,12 +50,15 @@ options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
unity-setup() {
- ./UnitySetup-${_version}${_build} -d "${startdir}" -l "${pkgdir}${_prefix}" -u $@
+ ./UnitySetup-${_version}${_build} \
+ --download-location="${startdir}" \
+ --install-location="${pkgdir}${_prefix}" \
+ --unattended $@
}
extract-component() {
msg2 "Extracting $1..."
- yes | unity-setup -c $1 > "/tmp/$1.log"
+ yes | unity-setup --components=$1 > "/tmp/$1.log"
}
prepare() {