summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonard König2015-08-27 15:48:33 +0200
committerLeonard König2015-08-27 15:48:33 +0200
commite52089d63dd401c408d5a3e07cc947ea33dcf3ff (patch)
treef8479bec077080e1d82bb4ad0855f6746b7c5020
parentbacbb22ea2a9bc0c00eafa307a9f0ce4334a62f1 (diff)
downloadaur-e52089d63dd401c408d5a3e07cc947ea33dcf3ff.tar.gz
change unity3d to unity-editor
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--unity-editor.install25
-rw-r--r--unity3d.install24
4 files changed, 31 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aadf174f5f69..9d305d41e110 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
-pkgbase = unity3d
+pkgbase = unity-editor
pkgdesc = The world's most popular development platform for creating 2D and 3D multiplatform games and interactive experiences.
pkgver = 5.1.0f3+2015082501
pkgrel = 2
url = http://unity3d.com/
- install = unity3d.install
+ install = unity-editor.install
arch = x86_64
license = custom
depends = desktop-file-utils
@@ -22,8 +22,8 @@ pkgbase = unity3d
optdepends = java-environment: for Android and Tizen exporting
optdepends = android-sdk: for Android Remote
optdepends = android-udev: for Android Remote
- conflicts = unity-editor
- replaces = unity-editor
+ conflicts = unity3d
+ replaces = unity3d
noextract = unity-editor-installer-5.1.0f3+2015082501.sh
options = !strip
source = http://download.unity3d.com/download_unity/unity-editor-installer-5.1.0f3+2015082501.sh
@@ -35,5 +35,5 @@ pkgbase = unity3d
sha256sums = a03aaf639c6ba56a0ef03a591f0f629a3e015a3a3c6999ecc0feb6b2284c901b
sha256sums = 7309ac206fbb6eb5f1a073bf22e2571e1a574410ab410138a19fb66c3eee21e3
-pkgname = unity3d
+pkgname = unity-editor
diff --git a/PKGBUILD b/PKGBUILD
index da46fcc702e1..ec2e49382e00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Maintainer: Leonard König <leonard.r.koenig at googlemail dot com>
# Maintainer: Oscar Morante <spacepluk at gmail dot com>
-pkgname=unity3d
+pkgname=unity-editor
_version=5.1.0
_build=f3
_buildtag=2015082501
@@ -29,8 +29,8 @@ optdepends=('ffmpeg: for WebGL exporting'
'java-environment: for Android and Tizen exporting'
'android-sdk: for Android Remote'
'android-udev: for Android Remote')
-conflicts=('unity-editor')
-replaces=('unity-editor')
+conflicts=('unity3d')
+replaces=('unity3d')
install="${pkgname}.install"
source=("http://download.unity3d.com/download_unity/unity-editor-installer-${pkgver}.sh"
"https://unity3d.com/legal/eula"
diff --git a/unity-editor.install b/unity-editor.install
index dab33ab3bb0c..9ff321d825f3 100644
--- a/unity-editor.install
+++ b/unity-editor.install
@@ -1,3 +1,24 @@
-postinstall() {
- ln -s /usr/bin/Unity /opt/Unity/Editor/Unity
+pre_install() {
+ echo -n "If you are using an AUR-Helper or building on a small partition (like /tmp),"
+ echo -n "you might want to change the build-/cache-directory as this package is rather big"
}
+
+post_install() {
+ echo -n "Updating desktop MIME database..."
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ echo " done."
+
+ echo -n "Updating icon cache..."
+ update-desktop-database -q
+ echo " done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+# vim:set sw=2 sts=2 et:
diff --git a/unity3d.install b/unity3d.install
deleted file mode 100644
index 9ff321d825f3..000000000000
--- a/unity3d.install
+++ /dev/null
@@ -1,24 +0,0 @@
-pre_install() {
- echo -n "If you are using an AUR-Helper or building on a small partition (like /tmp),"
- echo -n "you might want to change the build-/cache-directory as this package is rather big"
-}
-
-post_install() {
- echo -n "Updating desktop MIME database..."
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- echo " done."
-
- echo -n "Updating icon cache..."
- update-desktop-database -q
- echo " done."
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-}
-
-# vim:set sw=2 sts=2 et: