summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2018-01-19 19:47:48 +0100
committerOscar Morante2018-01-19 19:47:48 +0100
commit3cb296b5516bae6a5801479b3acf9c6785727ac7 (patch)
tree08674af0ea5f5e463da11b264de8ae7a7453b24f
parent2159fde2c4a81843d388beea517484f1171efb6e (diff)
downloadaur-3cb296b5516bae6a5801479b3acf9c6785727ac7.tar.gz
workaround bug in unity installer
There's a bug in the installer that tries to do GUI stuff when you use the contracted version of the parameters. Now it should work on chroots/headless systems.
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 137ee442f60e..4a218d511456 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,12 +27,15 @@ options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
unity-setup() {
- ./UnitySetup-${_version}${_build} -d "${startdir}" -l "${pkgdir}${_prefix}" -u $@
+ ./UnitySetup-${_version}${_build} \
+ --download-location="${startdir}" \
+ --install-location="${pkgdir}${_prefix}" \
+ --unattended $@
}
extract-component() {
msg2 "Extracting $1..."
- yes | unity-setup -c $1 > "/tmp/$1.log"
+ yes | unity-setup --components=$1 > "/tmp/$1.log"
}
prepare() {