summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2018-01-19 19:49:19 +0100
committerOscar Morante2018-01-19 19:49:19 +0100
commit0fb2ce2749e9b641947e5f7b9b022a7d08bffbbd (patch)
tree6acf97e3b64d1be49c3b0b74731a32bab967bd4f
parentfff0cf2f059eff13cd6877d0cc44e664e4cecbed (diff)
downloadaur-0fb2ce2749e9b641947e5f7b9b022a7d08bffbbd.tar.gz
workaround bug in unity installer
There's a bug in the installer that tries to do GUI stuff when you use the contracted version of the parameters. Now it should work on chroots/headless systems.
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6eb739519c1b..cd41e995f5a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,12 +23,15 @@ options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
unity-setup() {
- ./UnitySetup-${_version}${_build} -d "${startdir}" -l "${pkgdir}${_prefix}" -u $@
+ ./UnitySetup-${_version}${_build} \
+ --download-location="${startdir}" \
+ --install-location="${pkgdir}${_prefix}" \
+ --unattended $@
}
extract-component() {
msg2 "Extracting $1..."
- yes | unity-setup -c $1 > "/tmp/$1.log"
+ yes | unity-setup --components=$1 > "/tmp/$1.log"
}
prepare() {