summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2018-02-21 17:18:46 +0100
committerOscar Morante2018-02-21 17:18:46 +0100
commit71f95468186cb29df59e534777cebe41b3c692da (patch)
tree489f3bbfce4333f6a49cc2aa432f23fbcc3e4dec
parent385163fe15e74cd07d9cea86bc30c330e803b51e (diff)
downloadaur-71f95468186cb29df59e534777cebe41b3c692da.tar.gz
update to new upstream version (2018.1.0b8)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d027453f2b02..e95b2fe4807f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Thu Dec 7 13:45:00 UTC 2017
pkgbase = unity-editor-beta-windows
pkgdesc = Allows building your Unity projects for the Windows platform
- pkgver = 2017.3.0f1+20171206
+ pkgver = 2018.1.0b8+20180221
pkgrel = 1
url = https://unity3d.com/
arch = x86_64
@@ -12,8 +10,8 @@ pkgbase = unity-editor-beta-windows
makedepends = libarchive
depends = unity-editor-beta
options = !strip
- source = http://beta.unity3d.com/download/3c89f8d277f5/UnitySetup-2017.3.0f1
- sha1sums = 864eec744e5ca360c41e6121ddbd4cbb48659fe4
+ source = http://beta.unity3d.com/download/ee2fb9f9da52/UnitySetup-2018.1.0b8
+ sha1sums = 1322e5922b3a5b37910b30e308740cc453211ebd
pkgname = unity-editor-beta-windows
diff --git a/PKGBUILD b/PKGBUILD
index 6a0fcfa0eca7..08654f4139ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Oscar Morante <spacepluk at gmail dot com>
-_version=2017.3.0
-_build=f1
-_buildtag=20171206
-_randomstring=3c89f8d277f5
+_version=2018.1.0
+_build=b8
+_buildtag=20180221
+_randomstring=ee2fb9f9da52
_prefix=/opt/UnityBeta
_unitydownloads="http://beta.unity3d.com/download/${_randomstring}"
#_keepdownloads=yes
@@ -18,7 +18,7 @@ license=('custom')
depends=('unity-editor-beta')
makedepends=('gtk2' 'libsoup' 'libarchive')
source=("${_unitydownloads}/UnitySetup-${_version}${_build}")
-sha1sums=('864eec744e5ca360c41e6121ddbd4cbb48659fe4')
+sha1sums=('1322e5922b3a5b37910b30e308740cc453211ebd')
options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
@@ -40,10 +40,10 @@ prepare() {
package_unity-editor-beta-windows() {
mkdir -p "${pkgdir}${_prefix}"
- extract-component Windows
+ extract-component Windows-Mono
if [ -z "${_keepdownloads}" ]; then
- rm "${startdir}/UnitySetup-Windows-Support-for-Editor-${_version}${_build}.pkg"
+ rm "${startdir}/UnitySetup-Windows-Mono-Support-for-Editor-${_version}${_build}.pkg"
fi
}