summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2016-04-19 18:44:32 +0200
committerGordian Edenhofer2016-04-19 18:44:32 +0200
commit0dc4dca6102ae4fa001c4dcf5957c44207bf1b43 (patch)
treebd6f8eedd005348e5b60ddff558784b28a2454bb
parentf2c377e8cf792e175230b98f4fbf9e14dfb1670e (diff)
downloadaur-0dc4dca6102ae4fa001c4dcf5957c44207bf1b43.tar.gz
upgpkg: unity-editor-bin 5.4.0b15+20160418-1
Put all bash variables in quotation marks.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5f743d5f7fb..2974410b3f8e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = unity-editor-bin
pkgdesc = The world's most popular development platform for creating 2D and 3D multiplatform games and interactive experiences.
- pkgver = 5.4.0b13+20160406
+ pkgver = 5.4.0b15+20160418
pkgrel = 1
url = https://unity3d.com/
install = unity-editor-bin.install
@@ -24,10 +24,10 @@ pkgbase = unity-editor-bin
optdepends = java-environment: for Android and Tizen exporting
optdepends = android-sdk: for Android Remote
optdepends = android-udev: for Android Remote
- provides = unity-editor=5.4.0b13+20160406
+ provides = unity-editor=5.4.0b15+20160418
conflicts = unity-editor
options = !strip
- source = http://download.unity3d.com/download_unity/linux/unity-editor-5.4.0b13+20160406_amd64.deb
- md5sums = 1acc8c7d74aaa0ae380ee02126674a24
+ source = http://download.unity3d.com/download_unity/linux/unity-editor-5.4.0b15+20160418_amd64.deb
+ md5sums = 815ab60084ef0be7960ed1b53b85cb9a
pkgname = unity-editor-bin
diff --git a/PKGBUILD b/PKGBUILD
index 43a6b341f509..0a60fb5206a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,9 @@ PKGEXT='.pkg.tar'
pkgname=unity-editor-bin
_version=5.4.0
-_build=b13
-_buildtag=20160406
-pkgver=${_version}${_build}+${_buildtag}
+_build=b15
+_buildtag=20160418
+pkgver="${_version}${_build}+${_buildtag}"
pkgrel=1
pkgdesc="The world's most popular development platform for creating 2D and 3D multiplatform games and interactive experiences."
arch=('x86_64')
@@ -28,7 +28,7 @@ conflicts=('unity-editor')
options=(!strip)
install="${pkgname}.install"
source=("http://download.unity3d.com/download_unity/linux/unity-editor-${pkgver}_amd64.deb")
-md5sums=('1acc8c7d74aaa0ae380ee02126674a24')
+md5sums=('815ab60084ef0be7960ed1b53b85cb9a')
prepare() {
if [[ "$(df . -BG --output=avail | awk -F'[^0-9]*' 'FNR==2 {print $2;}')" -le "10" ]]; then
@@ -46,18 +46,18 @@ package() {
mv opt "${pkgdir}"
# Setting permissions on chrome-sandbox - necessary to run the program
- chown root:root "${pkgdir}"/opt/Unity/Editor/chrome-sandbox
- chmod 4755 "${pkgdir}"/opt/Unity/Editor/chrome-sandbox
+ chown root:root "${pkgdir}/opt/Unity/Editor/chrome-sandbox"
+ chmod 4755 "${pkgdir}/opt/Unity/Editor/chrome-sandbox"
# Linking executables (symlinking does not work!)
- mkdir -p "${pkgdir}"/usr/bin
+ mkdir -p "${pkgdir}/usr/bin"
#ln -s /opt/Unity/Editor/Unity "${pkgdir}"/usr/bin/unity-editor
#ln -s /opt/Unity/MonoDevelop/bin/monodevelop "${pkgdir}"/usr/bin/unity-monodevelop
echo -e "#!/bin/sh\nexec /opt/Unity/Editor/Unity \"$@\"" > "${pkgdir}"/usr/bin/unity-editor
- echo -e "#!/bin/sh\n\n# This prevents the editor from crashing when opening projects on some systems\nunset GTK_IM_MODULE\n\nexec /opt/Unity/MonoDevelop/bin/monodevelop \"$@\"" > "${pkgdir}"/usr/bin/unity-monodevelop
- chmod 755 "${pkgdir}"/usr/bin/unity-editor "${pkgdir}"/usr/bin/unity-monodevelop
+ echo -e "#!/bin/sh\n\n# This prevents the editor from crashing when opening projects on some systems\nunset GTK_IM_MODULE\n\nexec /opt/Unity/MonoDevelop/bin/monodevelop \"$@\"" > "${pkgdir}/usr/bin/unity-monodevelop"
+ chmod 755 "${pkgdir}/usr/bin/unity-editor" "${pkgdir}/usr/bin/unity-monodevelop"
# Refering to the online license
- mkdir -p "${pkgdir}"/usr/share/licenses/${pkgname}
- echo "Please refer to https://unity3d.com/legal/eula for detailed license information." > "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ echo "Please refer to https://unity3d.com/legal/eula for detailed license information." > "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}