summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2018-01-19 19:34:13 +0100
committerOscar Morante2018-01-19 19:38:57 +0100
commit614a6fa43e6d0fdf10b7db277cfdb3127f6c8eed (patch)
tree4e5bcd1abfbf2542855a2f987dea8f8f1d8be0fc
parent0fc78e78cae121e6008f0a4f02b17e180cb6a917 (diff)
downloadaur-614a6fa43e6d0fdf10b7db277cfdb3127f6c8eed.tar.gz
workaround bug in unity installer
There's a bug in the installer that tries to do GUI stuff when you use the contracted version of the parameters. Now it should work on chroots/headless systems.
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7aca21da8d18..5dc3c5224491 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ _unitydownloads="http://beta.unity3d.com/download/${_randomstring}"
pkgname=unity-editor-doc
pkgver=${_version}${_build}+${_buildtag}
-pkgrel=1
+pkgrel=2
pkgdesc="Unity User Manual and Scripting API Reference."
arch=('x86_64')
url='https://unity3d.com/'
@@ -23,12 +23,15 @@ options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
unity-setup() {
- ./UnitySetup-${_version}${_build} -d "${startdir}" -l "${pkgdir}${_prefix}" -u $@
+ ./UnitySetup-${_version}${_build} \
+ --download-location="${startdir}" \
+ --install-location="${pkgdir}${_prefix}" \
+ --unattended $@
}
extract-component() {
msg2 "Extracting $1..."
- yes | unity-setup -c $1 > "/tmp/$1.log"
+ yes | unity-setup --components=$1 > "/tmp/$1.log"
}
prepare() {