summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2018-09-02 21:05:18 +0300
committerOscar Morante2018-09-02 21:05:18 +0300
commit9e4b624ccb50b474da2eb2e645361cfc756a9e45 (patch)
tree7eaac35c620c468900a4a54ca501097ca178ad7b
parent960829cbcf6a7eded582da067bde5d198c86601d (diff)
downloadaur-9e4b624ccb50b474da2eb2e645361cfc756a9e45.tar.gz
update to new upstream version (2018.2.6f1)
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD41
2 files changed, 12 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 760069f623d3..cdacd4701990 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = unity-editor-doc
pkgdesc = Unity User Manual and Scripting API Reference.
- pkgver = 2018.2.5f1+20180828
+ pkgver = 2018.2.6f1
pkgrel = 1
url = https://unity3d.com/
arch = x86_64
license = custom
- makedepends = gtk2
- makedepends = libsoup
- makedepends = libarchive
depends = unity-editor
options = !strip
- source = http://beta.unity3d.com/download/88f43da96871/UnitySetup-2018.2.5f1
- sha1sums = 2f1d98a40a6662fb7f1f722b311350b506fb931f
+ source = https://docs.unity3d.com/2018.2/Documentation/uploads/UnityDocumentation.zip
+ sha1sums = 85e84655742fab6012b0b9eade87dc06b647a202
pkgname = unity-editor-doc
diff --git a/PKGBUILD b/PKGBUILD
index 69caaadd71f2..3a74f5498c09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,26 @@
-# Maintainer: Oscar Morante <spacepluk at gmail dot com>
+# Maintainer: Oscar Morante <spacepluk@gmail.com>
-_version=2018.2.5
+_version=2018.2.6
_build=f1
-_buildtag=20180828
-_randomstring=88f43da96871
+_randomstring=c591d9a97a0b
_prefix=/opt/Unity
-_unitydownloads="http://beta.unity3d.com/download/${_randomstring}"
-#_keepsources=yes
pkgname=unity-editor-doc
-pkgver=${_version}${_build}+${_buildtag}
+pkgver=${_version}${_build}
pkgrel=1
pkgdesc="Unity User Manual and Scripting API Reference."
arch=('x86_64')
url='https://unity3d.com/'
license=('custom')
depends=('unity-editor')
-makedepends=('gtk2' 'libsoup' 'libarchive')
-source=("${_unitydownloads}/UnitySetup-${_version}${_build}")
-sha1sums=('2f1d98a40a6662fb7f1f722b311350b506fb931f')
+source=("https://docs.unity3d.com/2018.2/Documentation/uploads/UnityDocumentation.zip")
+sha1sums=('85e84655742fab6012b0b9eade87dc06b647a202')
options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
-unity-setup() {
- ./UnitySetup-${_version}${_build} \
- --download-location="${startdir}" \
- --install-location="${pkgdir}${_prefix}" \
- --unattended $@
-}
-
-extract-component() {
- msg2 "Extracting $1..."
- yes | unity-setup --components=$1 > "/tmp/$1.log"
-}
-
-prepare() {
- chmod +x "${srcdir}/UnitySetup-${_version}${_build}"
-}
-
package() {
- mkdir -p "${pkgdir}${_prefix}"
- extract-component Documentation
-
- if [ -z "${_keepsources}" ]; then
- rm "${startdir}/Documentation.pkg"
- fi
+ _dest="${pkgdir}${_prefix}/Editor/Data"
+ install -d "${_dest}"
+ mv "$(find "${srcdir}" -name Documentation)" "${_dest}"
}