summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2018-01-03 10:02:11 +0100
committerOscar Morante2018-01-03 10:04:36 +0100
commite01e5a27ed4ffd305f748236c81a773762421a9e (patch)
tree12dd857c55331c13be666574e4fca0bfa23140ea
downloadaur-e01e5a27ed4ffd305f748236c81a773762421a9e.tar.gz
first commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..505437505c44
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Jan 3 09:04:09 UTC 2018
+pkgbase = unity-editor-doc
+ pkgdesc = Unity User Manual and Scripting API Reference.
+ pkgver = 2017.3.0f1+20171206
+ pkgrel = 1
+ url = https://unity3d.com/
+ arch = x86_64
+ license = custom
+ makedepends = gtk2
+ makedepends = libsoup
+ makedepends = libarchive
+ depends = unity-editor
+ options = !strip
+ source = http://beta.unity3d.com/download/3c89f8d277f5/UnitySetup-2017.3.0f1
+ sha1sums = 864eec744e5ca360c41e6121ddbd4cbb48659fe4
+
+pkgname = unity-editor-doc
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1fb49816c16c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Oscar Morante <spacepluk at gmail dot com>
+
+_version=2017.3.0
+_build=f1
+_buildtag=20171206
+_randomstring=3c89f8d277f5
+_prefix=/opt/Unity
+_unitydownloads="http://beta.unity3d.com/download/${_randomstring}"
+#_keepsources=yes
+
+pkgname=unity-editor-doc
+pkgver=${_version}${_build}+${_buildtag}
+pkgrel=1
+pkgdesc="Unity User Manual and Scripting API Reference."
+arch=('x86_64')
+url='https://unity3d.com/'
+license=('custom')
+depends=('unity-editor')
+makedepends=('gtk2' 'libsoup' 'libarchive')
+source=("${_unitydownloads}/UnitySetup-${_version}${_build}")
+sha1sums=('864eec744e5ca360c41e6121ddbd4cbb48659fe4')
+options=(!strip)
+PKGEXT='.pkg.tar' # Prevent compressing of the final package
+
+unity-setup() {
+ ./UnitySetup-${_version}${_build} -d "${startdir}" -l "${pkgdir}${_prefix}" -u $@
+}
+
+extract-component() {
+ msg2 "Extracting $1..."
+ yes | unity-setup -c $1 > "/tmp/$1.log"
+}
+
+prepare() {
+ chmod +x "${srcdir}/UnitySetup-${_version}${_build}"
+}
+
+package() {
+ mkdir -p "${pkgdir}${_prefix}"
+ extract-component Documentation
+
+ if [ -z "${_keepsources}" ]; then
+ rm "${startdir}/Documentation.pkg"
+ fi
+}
+