summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2018-01-19 19:36:06 +0100
committerOscar Morante2018-01-19 19:39:01 +0100
commitb233f528b38d90a12a875f5e0cb973587c79b2e5 (patch)
treef507be727dafa27c8973fbdca248e9a6ebc2cd37
parent841f10facce8c2d643980a001db13d9f54bb7bf9 (diff)
downloadaur-b233f528b38d90a12a875f5e0cb973587c79b2e5.tar.gz
workaround bug in unity installer
There's a bug in the installer that tries to do GUI stuff when you use the contracted version of the parameters. Now it should work on chroots/headless systems.
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2cb5f8de297e..ba05169dec1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ _unitydownloads="http://beta.unity3d.com/download/${_randomstring}"
pkgname=unity-editor-ios
pkgver=${_version}${_build}+${_buildtag}
-pkgrel=1
+pkgrel=2
pkgdesc="Allows building your Unity projects for the iOS platform"
arch=('x86_64')
url='https://unity3d.com/'
@@ -23,12 +23,15 @@ options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
unity-setup() {
- ./UnitySetup-${_version}${_build} -d "${startdir}" -l "${pkgdir}${_prefix}" -u $@
+ ./UnitySetup-${_version}${_build} \
+ --download-location="${startdir}" \
+ --install-location="${pkgdir}${_prefix}" \
+ --unattended $@
}
extract-component() {
msg2 "Extracting $1..."
- yes | unity-setup -c $1 > "/tmp/$1.log"
+ yes | unity-setup --components=$1 > "/tmp/$1.log"
}
prepare() {