summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2018-07-02 20:20:10 +0200
committerOscar Morante2018-07-02 20:20:10 +0200
commit763cb843f6ba4f920c23765835c6a6a6d428bd57 (patch)
tree9eb05ea52a38831bbe8b5f6f7bbb42879e9c28f9
downloadaur-763cb843f6ba4f920c23765835c6a6a6d428bd57.tar.gz
fist commit
-rw-r--r--.SRCINFO44
-rw-r--r--PKGBUILD93
-rwxr-xr-xunity-editor-lts10
-rw-r--r--unity-editor-lts-icon.pngbin0 -> 25613 bytes
-rw-r--r--unity-editor-lts.desktop10
5 files changed, 157 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce4d1919851f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,44 @@
+pkgbase = unity-editor-lts
+ pkgdesc = The world's most popular development platform for creating 2D and 3D multiplatform games and interactive experiences.
+ pkgver = 2017.4.4f1+20180525
+ pkgrel = 1
+ epoch = 1
+ url = https://unity3d.com/
+ arch = x86_64
+ license = custom
+ makedepends = gtk2
+ makedepends = libsoup
+ makedepends = libarchive
+ depends = desktop-file-utils
+ depends = xdg-utils
+ depends = gcc-libs
+ depends = lib32-gcc-libs
+ depends = gconf
+ depends = libgl
+ depends = glu
+ depends = nss
+ depends = libpng12
+ depends = libxtst
+ depends = libpqxx
+ depends = npm
+ optdepends = unity-editor-lts-doc
+ optdepends = unity-editor-lts-standardassets
+ optdepends = unity-editor-lts-example
+ optdepends = unity-editor-lts-android
+ optdepends = unity-editor-lts-ios
+ optdepends = unity-editor-lts-mac
+ optdepends = unity-editor-lts-webgl
+ optdepends = unity-editor-lts-windows
+ optdepends = unity-editor-lts-facebook
+ options = !strip
+ source = http://beta.unity3d.com/download/e685bfa3c483/UnitySetup-2017.4.4f1
+ source = unity-editor-lts
+ source = unity-editor-lts.desktop
+ source = unity-editor-lts-icon.png
+ sha1sums = 61af707a8a8e78ef4d05c474c0c3ff43f30d8027
+ sha1sums = c2a0643216d9733fe6364ad2036272a92352cf99
+ sha1sums = 359516eed53621b070a2599aefe91a4e62396aba
+ sha1sums = fddf4861974f88f0565de7f54f7418204e729894
+
+pkgname = unity-editor-lts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3c339e76607
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,93 @@
+# Maintainer: Oscar Morante <spacepluk at gmail dot com>
+
+_version=2017.4.4
+_build=f1
+_buildtag=20180525
+_randomstring=e685bfa3c483
+_prefix=/opt/UnityLts
+_unitydownloads="http://beta.unity3d.com/download/${_randomstring}"
+#_keepdownloads=yes
+
+pkgname=unity-editor-lts
+pkgver=${_version}${_build}+${_buildtag}
+pkgrel=1
+epoch=1
+pkgdesc="The world's most popular development platform for creating 2D and 3D multiplatform games and interactive experiences."
+arch=('x86_64')
+url='https://unity3d.com/'
+license=('custom')
+depends=('desktop-file-utils'
+ 'xdg-utils'
+ 'gcc-libs'
+ 'lib32-gcc-libs'
+ 'gconf'
+ 'libgl'
+ 'glu'
+ 'nss'
+ 'libpng12'
+ 'libxtst'
+ 'libpqxx'
+ 'npm')
+optdepends=('unity-editor-lts-doc'
+ 'unity-editor-lts-standardassets'
+ 'unity-editor-lts-example'
+ 'unity-editor-lts-android'
+ 'unity-editor-lts-ios'
+ 'unity-editor-lts-mac'
+ 'unity-editor-lts-webgl'
+ 'unity-editor-lts-windows'
+ 'unity-editor-lts-facebook')
+makedepends=('gtk2' 'libsoup' 'libarchive')
+source=("${_unitydownloads}/UnitySetup-${_version}${_build}"
+ 'unity-editor-lts'
+ 'unity-editor-lts.desktop'
+ 'unity-editor-lts-icon.png')
+sha1sums=('61af707a8a8e78ef4d05c474c0c3ff43f30d8027'
+ 'c2a0643216d9733fe6364ad2036272a92352cf99'
+ '359516eed53621b070a2599aefe91a4e62396aba'
+ 'fddf4861974f88f0565de7f54f7418204e729894')
+options=(!strip)
+PKGEXT='.pkg.tar' # Prevent compressing of the final package
+
+unity-setup() {
+ ./UnitySetup-${_version}${_build} \
+ --download-location="${startdir}" \
+ --install-location="${pkgdir}${_prefix}" \
+ --unattended $@
+}
+
+extract-component() {
+ msg2 "Extracting $1..."
+ yes | unity-setup --components=$1 > "/tmp/$1.log"
+}
+
+prepare() {
+ chmod +x "${srcdir}/UnitySetup-${_version}${_build}"
+}
+
+package() {
+ msg2 "Extracting EULA..."
+ echo n | unity-setup | head -n -2 > "${srcdir}/EULA"
+
+ mkdir -p "${pkgdir}${_prefix}"
+ extract-component Unity
+
+ if [ -z "${_keepdownloads}" ]; then
+ rm "${startdir}/Unity.tar.xz"
+ fi
+
+ # HACK: fixes WebGL builds by adding a symlink (python -> python2) to the PATH
+ ln -s /usr/bin/python2 "${pkgdir}${_prefix}/Editor/python"
+
+ # Fix permissions
+ find "${pkgdir}${_prefix}/Editor/Data" -type d -exec chmod ga+rx {} \;
+
+ # Add version to desktop file
+ sed -i "/^Version=/c\Version=${_version}${_build}" "${srcdir}/unity-editor-lts.desktop"
+
+ install -Dm644 -t "${pkgdir}/usr/share/applications" "${srcdir}/unity-editor-lts.desktop"
+ install -Dm644 -t "${pkgdir}/usr/share/icons/hicolor/256x256/apps" "${srcdir}/unity-editor-lts-icon.png"
+ install -Dm755 -t "${pkgdir}/usr/bin" "${srcdir}/unity-editor-lts"
+ install -Dm644 "${srcdir}/EULA" "${pkgdir}/usr/share/licenses/${pkgname}/EULA"
+}
+
diff --git a/unity-editor-lts b/unity-editor-lts
new file mode 100755
index 000000000000..9ca0ae0df056
--- /dev/null
+++ b/unity-editor-lts
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+# This prevents the editor from crashing when opening projects in some systems
+unset GTK_IM_MODULE
+
+# HACK: fixes WebGL builds by adding a symlink (python -> python2) to the PATH
+export PATH=/opt/UnityLts/Editor:$PATH
+
+mkdir -p ~/.local/share/unity3d/Packages
+exec /opt/UnityLts/Editor/Unity -no-throttle-updates "$@"
diff --git a/unity-editor-lts-icon.png b/unity-editor-lts-icon.png
new file mode 100644
index 000000000000..ef980860bbf5
--- /dev/null
+++ b/unity-editor-lts-icon.png
Binary files differ
diff --git a/unity-editor-lts.desktop b/unity-editor-lts.desktop
new file mode 100644
index 000000000000..d115b42b2b5a
--- /dev/null
+++ b/unity-editor-lts.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=
+Name=Unity LTS
+Exec=/usr/bin/unity-editor-lts
+Icon=unity-editor-lts-icon
+Terminal=false
+Type=Application
+StartupNotify=true
+Categories=Development;IDE;Application;
+MimeType=x-scheme-handler/com.unity3d.kharma;