summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2018-07-02 20:20:31 +0200
committerOscar Morante2018-07-02 20:20:31 +0200
commitb8941e7138cd6b301e2c6b26764f02176cc8784e (patch)
tree22bae6aef0662298468df6652980c94e64a1d6d7
downloadaur-b8941e7138cd6b301e2c6b26764f02176cc8784e.tar.gz
first commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD48
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c81dd13d6782
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = unity-editor-lts-standardassets
+ pkgdesc = Unity Standard Assets for easily getting started building projects in Unity.
+ pkgver = 2017.4.4f1+20180525
+ pkgrel = 1
+ url = https://unity3d.com/
+ arch = x86_64
+ license = custom
+ makedepends = gtk2
+ makedepends = libsoup
+ makedepends = libarchive
+ depends = unity-editor-lts
+ options = !strip
+ source = http://beta.unity3d.com/download/e685bfa3c483/UnitySetup-2017.4.4f1
+ sha1sums = 61af707a8a8e78ef4d05c474c0c3ff43f30d8027
+
+pkgname = unity-editor-lts-standardassets
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1eb39eaf2340
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Oscar Morante <spacepluk at gmail dot com>
+
+_version=2017.4.4
+_build=f1
+_buildtag=20180525
+_randomstring=e685bfa3c483
+_prefix=/opt/UnityLts
+_unitydownloads="http://beta.unity3d.com/download/${_randomstring}"
+#_keepdownloads=yes
+
+pkgname=unity-editor-lts-standardassets
+pkgver=${_version}${_build}+${_buildtag}
+pkgrel=1
+pkgdesc="Unity Standard Assets for easily getting started building projects in Unity."
+arch=('x86_64')
+url='https://unity3d.com/'
+license=('custom')
+depends=('unity-editor-lts')
+makedepends=('gtk2' 'libsoup' 'libarchive')
+source=("${_unitydownloads}/UnitySetup-${_version}${_build}")
+sha1sums=('61af707a8a8e78ef4d05c474c0c3ff43f30d8027')
+options=(!strip)
+PKGEXT='.pkg.tar' # Prevent compressing of the final package
+
+unity-setup() {
+ ./UnitySetup-${_version}${_build} \
+ --download-location="${startdir}" \
+ --install-location="${pkgdir}${_prefix}" \
+ --unattended $@
+}
+
+extract-component() {
+ msg2 "Extracting $1..."
+ yes | unity-setup --components=$1 > "/tmp/$1.log"
+}
+
+prepare() {
+ chmod +x "${srcdir}/UnitySetup-${_version}${_build}"
+}
+
+package() {
+ extract-component StandardAssets
+
+ if [ -z "${_keepdownloads}" ]; then
+ rm "${startdir}/StandardAssets.pkg"
+ fi
+}
+