summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2018-09-03 17:20:40 +0300
committerOscar Morante2018-09-03 17:20:40 +0300
commitdbf3c00acc7575adb69115bcadfadcf3fa68add3 (patch)
tree6db92c39361d00de732871c4a53c535bbc7c6ce0
parent55ee26ac85e7f79a85f90dbccf93ca71f80f46db (diff)
downloadaur-dbf3c00acc7575adb69115bcadfadcf3fa68add3.tar.gz
update to new upstream version (2017.4.10f1)
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD41
2 files changed, 12 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a64eb7702301..9c89a78987d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
pkgbase = unity-editor-lts-webgl
pkgdesc = Allows building your Unity projects for the WebGL platform
- pkgver = 2017.4.9f1+20180816
+ pkgver = 2017.4.10f1
pkgrel = 1
url = https://unity3d.com/
arch = x86_64
license = custom
- makedepends = gtk2
- makedepends = libsoup
- makedepends = libarchive
depends = unity-editor-lts
depends = ffmpeg
depends = gzip
options = !strip
- source = http://beta.unity3d.com/download/cc814e4d942d/UnitySetup-2017.4.9f1
- sha1sums = 6d4284af0002b3f06a6923649d57ffd045999756
+ source = https://download.unity3d.com/download_unity/f2cce2a5991f/LinuxEditorTargetInstaller/UnitySetup-WebGL-Support-for-Editor-2017.4.10f1.tar.xz
+ md5sums = c91c6738604fdb1e9ff09e2b2fd39954
pkgname = unity-editor-lts-webgl
diff --git a/PKGBUILD b/PKGBUILD
index 3c3b3a25928f..21c7d65537ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,12 @@
-# Maintainer: Oscar Morante <spacepluk at gmail dot com>
+# Maintainer: Oscar Morante <spacepluk@gmail.com>
-_version=2017.4.9
+_version=2017.4.10
_build=f1
-_buildtag=20180816
-_randomstring=cc814e4d942d
+_randomstring=f2cce2a5991f
_prefix=/opt/UnityLts
-_unitydownloads="http://beta.unity3d.com/download/${_randomstring}"
-#_keepdownloads=yes
pkgname=unity-editor-lts-webgl
-pkgver=${_version}${_build}+${_buildtag}
+pkgver=${_version}${_build}
pkgrel=1
pkgdesc="Allows building your Unity projects for the WebGL platform"
arch=('x86_64')
@@ -18,34 +15,14 @@ license=('custom')
depends=('unity-editor-lts'
'ffmpeg'
'gzip')
-makedepends=('gtk2' 'libsoup' 'libarchive')
-source=("${_unitydownloads}/UnitySetup-${_version}${_build}")
-sha1sums=('6d4284af0002b3f06a6923649d57ffd045999756')
+source=("https://download.unity3d.com/download_unity/${_randomstring}/LinuxEditorTargetInstaller/UnitySetup-WebGL-Support-for-Editor-${_version}${_build}.tar.xz")
+md5sums=('c91c6738604fdb1e9ff09e2b2fd39954')
options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
-unity-setup() {
- ./UnitySetup-${_version}${_build} \
- --download-location="${startdir}" \
- --install-location="${pkgdir}${_prefix}" \
- --unattended $@
-}
-
-extract-component() {
- msg2 "Extracting $1..."
- yes | unity-setup --components=$1 > "/tmp/$1.log"
-}
-
-prepare() {
- chmod +x "${srcdir}/UnitySetup-${_version}${_build}"
-}
-
package() {
- mkdir -p "${pkgdir}${_prefix}"
- extract-component WebGL
-
- if [ -z "${_keepdownloads}" ]; then
- rm "${startdir}/UnitySetup-WebGL-Support-for-Editor-${_version}${_build}.tar.xz"
- fi
+ _dest="${pkgdir}${_prefix}"
+ install -d "${_dest}"
+ mv Editor "${_dest}"
}