summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2018-09-03 17:20:41 +0300
committerOscar Morante2018-09-03 17:20:41 +0300
commit1428114c1dffb74aae9db16d4762d3127526d4b3 (patch)
tree3a19f9c13d0d8640ca5265d1657ed9b17fb58c16
parentdc79a32de09fb4a088b800b2b9a9b4d9c339a79e (diff)
downloadaur-1428114c1dffb74aae9db16d4762d3127526d4b3.tar.gz
update to new upstream version (2017.4.10f1)
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD43
2 files changed, 15 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e99374f7dfa0..cb56dda0e662 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = unity-editor-lts-windows
pkgdesc = Allows building your Unity projects for the Windows platform
- pkgver = 2017.4.9f1+20180816
+ pkgver = 2017.4.10f1
pkgrel = 1
url = https://unity3d.com/
arch = x86_64
license = custom
- makedepends = gtk2
- makedepends = libsoup
- makedepends = libarchive
+ makedepends = cpio
depends = unity-editor-lts
options = !strip
- source = http://beta.unity3d.com/download/cc814e4d942d/UnitySetup-2017.4.9f1
- sha1sums = 6d4284af0002b3f06a6923649d57ffd045999756
+ source = https://download.unity3d.com/download_unity/f2cce2a5991f/MacEditorTargetInstaller/UnitySetup-Windows-Support-for-Editor-2017.4.10f1.pkg
+ md5sums = 37e493d155ec88290317bee3808aa8b1
pkgname = unity-editor-lts-windows
diff --git a/PKGBUILD b/PKGBUILD
index f29ddd7fe4fa..afa835b54ad6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,28 @@
-# Maintainer: Oscar Morante <spacepluk at gmail dot com>
+# Maintainer: Oscar Morante <spacepluk@gmail.com>
-_version=2017.4.9
+_version=2017.4.10
_build=f1
-_buildtag=20180816
-_randomstring=cc814e4d942d
+_randomstring=f2cce2a5991f
_prefix=/opt/UnityLts
-_unitydownloads="http://beta.unity3d.com/download/${_randomstring}"
-#_keepdownloads=yes
pkgname=unity-editor-lts-windows
-pkgver=${_version}${_build}+${_buildtag}
+pkgver=${_version}${_build}
pkgrel=1
pkgdesc="Allows building your Unity projects for the Windows platform"
arch=('x86_64')
url='https://unity3d.com/'
license=('custom')
depends=('unity-editor-lts')
-makedepends=('gtk2' 'libsoup' 'libarchive')
-source=("${_unitydownloads}/UnitySetup-${_version}${_build}")
-sha1sums=('6d4284af0002b3f06a6923649d57ffd045999756')
+makedepends=('cpio')
+source=("https://download.unity3d.com/download_unity/${_randomstring}/MacEditorTargetInstaller/UnitySetup-Windows-Support-for-Editor-${_version}${_build}.pkg")
+md5sums=('37e493d155ec88290317bee3808aa8b1')
options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
-unity-setup() {
- ./UnitySetup-${_version}${_build} \
- --download-location="${startdir}" \
- --install-location="${pkgdir}${_prefix}" \
- --unattended $@
-}
-
-extract-component() {
- msg2 "Extracting $1..."
- yes | unity-setup --components=$1 > "/tmp/$1.log"
-}
-
-prepare() {
- chmod +x "${srcdir}/UnitySetup-${_version}${_build}"
-}
-
package() {
- mkdir -p "${pkgdir}${_prefix}"
- extract-component Windows
-
- if [ -z "${_keepdownloads}" ]; then
- rm "${startdir}/UnitySetup-Windows-Support-for-Editor-${_version}${_build}.pkg"
- fi
+ _dest="${pkgdir}/${_prefix}/Editor/Data/PlaybackEngines/WindowsStandaloneSupport"
+ install -d "${_dest}"
+ cd "${_dest}"
+ cat "${srcdir}/TargetSupport.pkg.tmp/Payload" | gzip -dc | cpio -i
}