summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2018-07-02 20:20:35 +0200
committerOscar Morante2018-07-02 20:20:35 +0200
commit1cd216f4e07a9447d0d128a7d48eddd383ccb037 (patch)
tree75bdd343d2c479b47f5764c41243e1ae6b1972cc
downloadaur-1cd216f4e07a9447d0d128a7d48eddd383ccb037.tar.gz
first commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD49
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe03a51e16b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = unity-editor-lts-windows
+ pkgdesc = Allows building your Unity projects for the Windows platform
+ pkgver = 2017.4.4f1+20180525
+ pkgrel = 1
+ url = https://unity3d.com/
+ arch = x86_64
+ license = custom
+ makedepends = gtk2
+ makedepends = libsoup
+ makedepends = libarchive
+ depends = unity-editor-lts
+ options = !strip
+ source = http://beta.unity3d.com/download/e685bfa3c483/UnitySetup-2017.4.4f1
+ sha1sums = 61af707a8a8e78ef4d05c474c0c3ff43f30d8027
+
+pkgname = unity-editor-lts-windows
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63f17cdb4d1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Oscar Morante <spacepluk at gmail dot com>
+
+_version=2017.4.4
+_build=f1
+_buildtag=20180525
+_randomstring=e685bfa3c483
+_prefix=/opt/UnityLts
+_unitydownloads="http://beta.unity3d.com/download/${_randomstring}"
+#_keepdownloads=yes
+
+pkgname=unity-editor-lts-windows
+pkgver=${_version}${_build}+${_buildtag}
+pkgrel=1
+pkgdesc="Allows building your Unity projects for the Windows platform"
+arch=('x86_64')
+url='https://unity3d.com/'
+license=('custom')
+depends=('unity-editor-lts')
+makedepends=('gtk2' 'libsoup' 'libarchive')
+source=("${_unitydownloads}/UnitySetup-${_version}${_build}")
+sha1sums=('61af707a8a8e78ef4d05c474c0c3ff43f30d8027')
+options=(!strip)
+PKGEXT='.pkg.tar' # Prevent compressing of the final package
+
+unity-setup() {
+ ./UnitySetup-${_version}${_build} \
+ --download-location="${startdir}" \
+ --install-location="${pkgdir}${_prefix}" \
+ --unattended $@
+}
+
+extract-component() {
+ msg2 "Extracting $1..."
+ yes | unity-setup --components=$1 > "/tmp/$1.log"
+}
+
+prepare() {
+ chmod +x "${srcdir}/UnitySetup-${_version}${_build}"
+}
+
+package() {
+ mkdir -p "${pkgdir}${_prefix}"
+ extract-component Windows
+
+ if [ -z "${_keepdownloads}" ]; then
+ rm "${startdir}/UnitySetup-Windows-Support-for-Editor-${_version}${_build}.pkg"
+ fi
+}
+