summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2018-01-19 19:36:26 +0100
committerOscar Morante2018-01-19 19:39:03 +0100
commit4d1005e7cf21c244f4ef83a2ae57f84de9476093 (patch)
tree94be20a20c69b3c4a8ce02ccbf739b8ac21ff3b5
parent81ceceaf8eb34d8a70565c6d0607e0981cd2dd42 (diff)
downloadaur-4d1005e7cf21c244f4ef83a2ae57f84de9476093.tar.gz
workaround bug in unity installer
There's a bug in the installer that tries to do GUI stuff when you use the contracted version of the parameters. Now it should work on chroots/headless systems.
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 951a7e5ac73c..d02b06a8b913 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ _unitydownloads="http://beta.unity3d.com/download/${_randomstring}"
pkgname=unity-editor-mac
pkgver=${_version}${_build}+${_buildtag}
-pkgrel=1
+pkgrel=2
pkgdesc="Allows building your Unity projects for the Mac platform"
arch=('x86_64')
url='https://unity3d.com/'
@@ -23,12 +23,15 @@ options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
unity-setup() {
- ./UnitySetup-${_version}${_build} -d "${startdir}" -l "${pkgdir}${_prefix}" -u $@
+ ./UnitySetup-${_version}${_build} \
+ --download-location="${startdir}" \
+ --install-location="${pkgdir}${_prefix}" \
+ --unattended $@
}
extract-component() {
msg2 "Extracting $1..."
- yes | unity-setup -c $1 > "/tmp/$1.log"
+ yes | unity-setup --components=$1 > "/tmp/$1.log"
}
prepare() {