summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2018-01-03 10:03:07 +0100
committerOscar Morante2018-01-03 10:04:44 +0100
commit8c6e81352fea535084f590788fb460cc2cb82983 (patch)
tree4c66bd287f41dc4d92d948b8a1e8c04c1b831206
downloadaur-8c6e81352fea535084f590788fb460cc2cb82983.tar.gz
first commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..593d3fb9b4f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Jan 3 09:04:10 UTC 2018
+pkgbase = unity-editor-mac
+ pkgdesc = Allows building your Unity projects for the Mac platform
+ pkgver = 2017.3.0f1+20171206
+ pkgrel = 1
+ url = https://unity3d.com/
+ arch = x86_64
+ license = custom
+ makedepends = gtk2
+ makedepends = libsoup
+ makedepends = libarchive
+ depends = unity-editor
+ options = !strip
+ source = http://beta.unity3d.com/download/3c89f8d277f5/UnitySetup-2017.3.0f1
+ sha1sums = 864eec744e5ca360c41e6121ddbd4cbb48659fe4
+
+pkgname = unity-editor-mac
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae9848090e8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Oscar Morante <spacepluk at gmail dot com>
+
+_version=2017.3.0
+_build=f1
+_buildtag=20171206
+_randomstring=3c89f8d277f5
+_prefix=/opt/Unity
+_unitydownloads="http://beta.unity3d.com/download/${_randomstring}"
+#_keepdownloads=yes
+
+pkgname=unity-editor-mac
+pkgver=${_version}${_build}+${_buildtag}
+pkgrel=1
+pkgdesc="Allows building your Unity projects for the Mac platform"
+arch=('x86_64')
+url='https://unity3d.com/'
+license=('custom')
+depends=('unity-editor')
+makedepends=('gtk2' 'libsoup' 'libarchive')
+source=("${_unitydownloads}/UnitySetup-${_version}${_build}")
+sha1sums=('864eec744e5ca360c41e6121ddbd4cbb48659fe4')
+options=(!strip)
+PKGEXT='.pkg.tar' # Prevent compressing of the final package
+
+unity-setup() {
+ ./UnitySetup-${_version}${_build} -d "${startdir}" -l "${pkgdir}${_prefix}" -u $@
+}
+
+extract-component() {
+ msg2 "Extracting $1..."
+ yes | unity-setup -c $1 > "/tmp/$1.log"
+}
+
+prepare() {
+ chmod +x "${srcdir}/UnitySetup-${_version}${_build}"
+}
+
+package() {
+ mkdir -p "${pkgdir}${_prefix}"
+ extract-component Mac
+
+ if [ -z "${_keepdownloads}" ]; then
+ rm "${startdir}/UnitySetup-Mac-Support-for-Editor-${_version}${_build}.pkg"
+ fi
+}
+