summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2018-05-08 18:54:32 +0300
committerOscar Morante2018-05-08 19:57:36 +0300
commit937dd8417d330f3d10526b5659cc051cc4ad4682 (patch)
treec10e3df443deec77161e4d7d102659a4464ab1f7
parentba17e20b3cc5696f27432f6eebaf6c99b83a0ad9 (diff)
downloadaur-937dd8417d330f3d10526b5659cc051cc4ad4682.tar.gz
update to new upstream version (2018.1.0f2)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 277094983872..6643a0a05914 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = unity-editor-mac
pkgdesc = Allows building your Unity projects for the Mac platform
- pkgver = 2017.4.0f1+20180501
+ pkgver = 2018.1.0f2+20180504
pkgrel = 1
url = https://unity3d.com/
arch = x86_64
@@ -10,8 +10,8 @@ pkgbase = unity-editor-mac
makedepends = libarchive
depends = unity-editor
options = !strip
- source = http://beta.unity3d.com/download/0ec691fce5c2/UnitySetup-2017.4.0f1
- sha1sums = b379e6df5d9d5f02047d37c3399a2b1bb5168dda
+ source = http://beta.unity3d.com/download/170f0691b973/UnitySetup-2018.1.0f2
+ sha1sums = 36104fa796172f3b9845e7c84aaccc7902b68ce2
pkgname = unity-editor-mac
diff --git a/PKGBUILD b/PKGBUILD
index 2a771a5d0043..3a4aa851eecb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Oscar Morante <spacepluk at gmail dot com>
-_version=2017.4.0
-_build=f1
-_buildtag=20180501
-_randomstring=0ec691fce5c2
+_version=2018.1.0
+_build=f2
+_buildtag=20180504
+_randomstring=170f0691b973
_prefix=/opt/Unity
_unitydownloads="http://beta.unity3d.com/download/${_randomstring}"
#_keepdownloads=yes
@@ -18,7 +18,7 @@ license=('custom')
depends=('unity-editor')
makedepends=('gtk2' 'libsoup' 'libarchive')
source=("${_unitydownloads}/UnitySetup-${_version}${_build}")
-sha1sums=('b379e6df5d9d5f02047d37c3399a2b1bb5168dda')
+sha1sums=('36104fa796172f3b9845e7c84aaccc7902b68ce2')
options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
@@ -40,10 +40,10 @@ prepare() {
package() {
mkdir -p "${pkgdir}${_prefix}"
- extract-component Mac
+ extract-component Mac-Mono
if [ -z "${_keepdownloads}" ]; then
- rm "${startdir}/UnitySetup-Mac-Support-for-Editor-${_version}${_build}.pkg"
+ rm "${startdir}/UnitySetup-Mac-Mono-Support-for-Editor-${_version}${_build}.pkg"
fi
}