summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiao-Long Chen2015-06-08 22:04:00 -0400
committerXiao-Long Chen2015-06-08 22:04:00 -0400
commit498cd99a47a1347b43ba6e4bd4c7070f10c3c287 (patch)
tree1d46e0f9ff1ff80c1beff83c0d1a3857c0061b32
downloadaur-498cd99a47a1347b43ba6e4bd4c7070f10c3c287.tar.gz
Import from old AUR
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD44
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef33e4d7d086
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by makepkg 4.2.0
+# Thu Jan 1 21:34:25 UTC 2015
+pkgbase = unity-system-compositor-bzr
+ pkgdesc = System compositor for Ubuntu
+ pkgver = 191
+ pkgrel = 1
+ url = https://launchpad.net/unity-system-compositor
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = boost
+ depends = cairo
+ depends = lightdm
+ depends = mesa-mir
+ depends = mir
+ depends = protobuf
+ depends = qt5-base
+ depends = xorg-server-mir
+ provides = unity-system-compositor
+ conflicts = unity-system-compositor
+ options = !emptydirs
+ source = bzr+https://code.launchpad.net/~unity-system-compositor-team/unity-system-compositor/trunk
+ sha512sums = SKIP
+
+pkgname = unity-system-compositor-bzr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d712b2a73a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+
+pkgname=unity-system-compositor-bzr
+pkgver=191
+pkgrel=1
+pkgdesc="System compositor for Ubuntu"
+arch=(i686 x86_64)
+url="https://launchpad.net/unity-system-compositor"
+license=(GPL)
+depends=(boost cairo lightdm mesa-mir mir protobuf qt5-base xorg-server-mir)
+makedepends=(cmake)
+provides=(unity-system-compositor)
+conflicts=(unity-system-compositor)
+options=(!emptydirs)
+source=(bzr+https://code.launchpad.net/~unity-system-compositor-team/unity-system-compositor/trunk)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd trunk
+ bzr revno
+}
+
+build() {
+ cd trunk
+ cmake . \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc \
+ -DMIR_ENABLE_TESTS=OFF
+ make
+}
+
+package() {
+ cd trunk
+ make DESTDIR="${pkgdir}/" install
+
+ mv "${pkgdir}"/usr/{sbin/*,bin/}
+
+ install -dm755 "${pkgdir}"/usr/share/lightdm/lightdm.conf.d/
+ install -m644 debian/10-unity-system-compositor.conf \
+ "${pkgdir}"/usr/share/lightdm/lightdm.conf.d/
+
+ install -m755 debian/unity-system-compositor.sleep "${pkgdir}"/usr/bin/
+ sed -i 's/sbin/bin/g' "${pkgdir}"/usr/bin/unity-system-compositor.sleep
+}