summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2020-03-28 09:44:31 +0100
committerOscar Morante2020-03-28 09:44:31 +0100
commit02f2352affbc45f78d72ef9b641fed2b9903471a (patch)
treefd69c71bc63feb61a1f425c985f70b7e1a14bea8
parent32793f25002c31ecdeda07d567c8fffdb80f8a09 (diff)
downloadaur-02f2352affbc45f78d72ef9b641fed2b9903471a.tar.gz
update to new upstream version (2.3)
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 899945f35403..1d34c0339526 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Oscar Morante <oscar@mooistudios.com>
pkgname=unityhub
-pkgver=2.2.2
+pkgver=2.3.0
pkgrel=1
pkgdesc="The Unity Hub is a standalone application that streamlines the way you find, download, and manage your Unity Projects and installations."
arch=('x86_64')
license=('custom')
depends=('gtk2' 'nss' 'p7zip' 'tar' 'gzip' 'cpio' 'zip' 'libxss' 'gconf' 'libxtst')
source=("${pkgname}-${pkgver}.AppImage::https://public-cdn.cloud.unity3d.com/hub/prod/UnityHub.AppImage")
-md5sums=('585164e362a5d354fcf9ce8521fbf1fa')
+md5sums=('d7cb21611e5f77fb6ebe03b01efd6ded')
PKGEXT='.pkg.tar'
build() {
@@ -33,22 +33,21 @@ package() {
install -d "${pkgdir}/usr/share/licenses/${pkgname}"
cp --no-preserve=all \
- "${srcdir}/squashfs-root/eula.txt" \
"${srcdir}"/squashfs-root/LICENSE* \
"${pkgdir}/usr/share/licenses/${pkgname}"
rm -r "${srcdir}/squashfs-root/AppRun" \
"${srcdir}/squashfs-root/unityhub.desktop" \
"${srcdir}/squashfs-root/usr/share" \
- "${srcdir}/squashfs-root/eula.txt" \
"${srcdir}"/squashfs-root/LICENSE*
install -d "${pkgdir}/opt/${pkgname}"
+ sed -i 's/^SCRIPT_DIR.*$/SCRIPT_DIR=\/opt\/unityhub/g' ${srcdir}/squashfs-root/unityhub
cp -r --no-preserve=all ${srcdir}/squashfs-root/* ${pkgdir}/opt/${pkgname}
install -d "${pkgdir}/usr/bin"
ln -s "/opt/${pkgname}/unityhub" "${pkgdir}/usr/bin/unityhub"
- chmod +x "${pkgdir}/opt/${pkgname}/unityhub"
+ chmod +x "${pkgdir}/opt/${pkgname}/unityhub" "${pkgdir}/opt/${pkgname}/unityhub-bin"
# Fix 7z permissions
chmod +x "${pkgdir}/opt/${pkgname}/resources" \
"${pkgdir}/opt/${pkgname}/resources/app.asar.unpacked" \