summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2019-10-22 14:38:02 +0200
committerOscar Morante2019-10-22 14:38:02 +0200
commit0463fcaa174364cbc941d20afa047bd1011d0a98 (patch)
tree08e9a124943ad26639375cad0bb273027726fd7e
parent0b5fbdc5e0740146be1ee6ad4c2c767b7a5926c4 (diff)
downloadaur-0463fcaa174364cbc941d20afa047bd1011d0a98.tar.gz
add Darkhogg's fix for AppImage extraction issues
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 801e05314d11..035560625c1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = unityhub
pkgdesc = The Unity Hub is a standalone application that streamlines the way you find, download, and manage your Unity Projects and installations.
pkgver = 2.1.2
- pkgrel = 1
+ pkgrel = 2
arch = x86_64
license = custom
depends = gtk2
diff --git a/PKGBUILD b/PKGBUILD
index b657e5e9be79..6f2bede7c9de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=unityhub
pkgver=2.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="The Unity Hub is a standalone application that streamlines the way you find, download, and manage your Unity Projects and installations."
arch=('x86_64')
license=('custom')
@@ -11,7 +11,7 @@ source=("${pkgname}-${pkgver}.AppImage::https://public-cdn.cloud.unity3d.com/hub
md5sums=('7cbff634d574a4e6da02fd1ce15bf2cb')
PKGEXT='.pkg.tar'
-package() {
+build() {
# Extract AppImage
chmod +x "${pkgname}-${pkgver}.AppImage"
"./${pkgname}-${pkgver}.AppImage" --appimage-extract
@@ -21,7 +21,9 @@ package() {
sed -i "/^Exec=/cExec=unityhub" "${_df}"
sed -i "s/^X-AppImage-Version=/Version=/" "${_df}"
sed -i "/^X-AppImage/d" "${_df}"
+}
+package() {
# Install
install -d "${pkgdir}/usr/share"
install -D ${_df} "${pkgdir}/usr/share/applications/unityhub.desktop"