summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNobbele2022-04-29 19:51:25 +0200
committerNobbele2022-04-29 19:51:25 +0200
commit5c59d26546aae2832b339c1ec3fff287c00af520 (patch)
tree05fe58f45a1eae81c44e34a1b28f28481d6dd010
parenta9dece786f2b6d3d3f750c3b1d981204397ed59f (diff)
downloadaur-5c59d26546aae2832b339c1ec3fff287c00af520.tar.gz
Changes to PKGBUILD
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0818fed4f26..7a1d564a76f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,9 +7,12 @@ pkgbase = unityhub
license = custom
depends = nss
depends = gtk3
- optdepends = libappindicator-gtk3: The DEB says this an optional dependency
- optdepends = gconf: Used by old editors
- optdepends = cpio: used for Android build support
+ depends = cpio
+ optdepends = libappindicator-gtk3: The official deb says this an optional dependency
+ optdepends = gconf: Required by Unity 2019.4 or older
+ optdepends = libicu50: May fix issues related to empty compiler errors
+ optdepends = icu70: : May fix issues related to empty compiler errors
+ conflicts = unityhub-beta
source = unityhub-3.1.2.deb::https://hub.unity3d.com/linux/repos/deb/pool/main/u/unity/unityhub_amd64/unityhub-amd64-3.1.2.deb
source = license.txt
sha256sums = d116f590e78e434857294cd422c8b5370364eef23186a1c42ab1d71562a0a627
diff --git a/PKGBUILD b/PKGBUILD
index f804eca7f205..c9a3cbb8cfc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Marius Glo <marius@mgl.dev>
# Maintainer: Nobbele <realnobbele@gmail.com>
# Contributor: Oscar Morante <oscar@mooistudios.com>
# Contributor: sinasio <synasius@gmail.com>
+# Contributor: Marius Glo <marius@mgl.dev>
pkgname=unityhub
pkgver=3.1.2
@@ -10,11 +10,12 @@ pkgdesc="The Unity Hub is a standalone application that streamlines the way you
url="https://unity.com/"
arch=('x86_64')
license=('custom')
-depends=('nss' 'gtk3')
+depends=('nss' 'gtk3' 'cpio')
optdepends=(
- 'libappindicator-gtk3: The DEB says this an optional dependency'
- 'gconf: Used by old editors'
- 'cpio: used for Android build support'
+ 'libappindicator-gtk3: The official deb says this an optional dependency'
+ 'gconf: Required by Unity 2019.4 or older'
+ 'libicu50: May fix issues related to empty compiler errors'
+ 'icu70: : May fix issues related to empty compiler errors'
)
source=(
"$pkgname-$pkgver.deb::https://hub.unity3d.com/linux/repos/deb/pool/main/u/unity/unityhub_amd64/unityhub-amd64-${pkgver}.deb"
@@ -24,6 +25,7 @@ sha256sums=(
'd116f590e78e434857294cd422c8b5370364eef23186a1c42ab1d71562a0a627'
'f0eb3a4bb148bb7f426e4f5b97e891265ac487710cbcba9282518537c7b5d833'
)
+conflicts=('unityhub-beta')
OPTIONS=(!strip)
package() {