summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2019-03-09 15:02:26 +0100
committerOscar Morante2019-03-09 15:02:26 +0100
commitc4efd632a4db59520ff0f853f04d4981ce723265 (patch)
tree69dcb8a55992ba1631d9720e1d64fb51cb8ad293
parentcb3781fcadf0fd552d078369ce3ba3dab9df3daf (diff)
downloadaur-c4efd632a4db59520ff0f853f04d4981ce723265.tar.gz
fix 7z permissions
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f5f54443ef8..d5dc10b144d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = unityhub
pkgdesc = The Unity Hub is a standalone application that streamlines the way you find, download, and manage your Unity Projects and installations.
pkgver = 1.6.0
- pkgrel = 1
+ pkgrel = 2
url = https://forum.unity.com/threads/unity-hub-v-1-5-0-is-now-available.627847/
arch = x86_64
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index 71cf634b9186..0cbe12b08e0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=unityhub
pkgver=1.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="The Unity Hub is a standalone application that streamlines the way you find, download, and manage your Unity Projects and installations."
arch=('x86_64')
url=https://forum.unity.com/threads/unity-hub-v-1-5-0-is-now-available.627847/
@@ -47,4 +47,11 @@ package() {
install -d "${pkgdir}/usr/bin"
ln -s "/opt/${pkgname}/unityhub" "${pkgdir}/usr/bin/unityhub"
chmod +x "${pkgdir}/opt/${pkgname}/unityhub"
+ # Fix 7z permissions
+ chmod +x "${pkgdir}/opt/${pkgname}/resources" \
+ "${pkgdir}/opt/${pkgname}/resources/app.asar.unpacked" \
+ "${pkgdir}/opt/${pkgname}/resources/app.asar.unpacked/external" \
+ "${pkgdir}/opt/${pkgname}/resources/app.asar.unpacked/external/7z" \
+ "${pkgdir}/opt/${pkgname}/resources/app.asar.unpacked/external/7z/linux64" \
+ "${pkgdir}/opt/${pkgname}/resources/app.asar.unpacked/external/7z/linux64/7z"
}