summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel M. Capella2020-10-11 19:24:40 -0400
committerDaniel M. Capella2020-10-11 19:24:40 -0400
commitfe62cdb580850f4c69397f6ca2682545b06d3665 (patch)
treecab3b582d8c662b257e0b1e7db0fdf45a67203e4
parentd1b8b73817d8a83f014b94e654196de5ae65b205 (diff)
downloadaur-fe62cdb580850f4c69397f6ca2682545b06d3665.tar.gz
Update pkgver function and touch up
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD38
2 files changed, 24 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aacd1c6ea45c..a1df0b0c6028 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = universal-ctags-git
- pkgdesc = Multilanguage reimplementation of the Unix ctags utility
- pkgver = 0.r6046.e65e91a2
+ pkgdesc = Generates an index (or tag) file of language objects found in source files
+ pkgver = 5.9.20201011.0.r12.g01b9fc866
pkgrel = 1
- url = https://ctags.io/
- arch = i686
+ url = https://ctags.io
arch = x86_64
license = GPL
makedepends = git
makedepends = python-docutils
- depends = libxml2
depends = jansson
- depends = libyaml
depends = libseccomp
+ depends = libxml2
+ depends = libyaml
provides = ctags
conflicts = ctags
source = git+https://github.com/universal-ctags/ctags.git
- md5sums = SKIP
+ b2sums = SKIP
pkgname = universal-ctags-git
diff --git a/PKGBUILD b/PKGBUILD
index 39842173a670..b41fb3b32063 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,30 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
# Contributor: VargArch <roels.jorick@gmail.com>
# Contributor: zsrkmyn
# Contributor: marsam
-_gitname=ctags
pkgname=universal-ctags-git
-pkgver=0.r6046.e65e91a2
+pkgver=5.9.20201011.0.r12.g01b9fc866
pkgrel=1
-pkgdesc="Multilanguage reimplementation of the Unix ctags utility"
-arch=('i686' 'x86_64')
-url="https://ctags.io/"
+pkgdesc='Generates an index (or tag) file of language objects found in source files'
+arch=('x86_64')
+url=https://ctags.io
license=('GPL')
-depends=('libxml2' 'jansson' 'libyaml' 'libseccomp')
+depends=('jansson' 'libseccomp' 'libxml2' 'libyaml')
makedepends=('git' 'python-docutils')
provides=('ctags')
conflicts=('ctags')
source=("git+https://github.com/universal-ctags/ctags.git")
-md5sums=('SKIP')
+b2sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_gitname}"
-
- printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd ctags
+ git describe --long --tags | sed 's/^p//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${_gitname}"
-
+ cd ctags
./autogen.sh
./configure --prefix=/usr \
--libexecdir=/usr/lib \
@@ -35,14 +33,14 @@ build() {
}
check() {
- cd "${srcdir}/${_gitname}"
-
- mkdir "${srcdir}/testhome"
- HOME="${srcdir}/testhome" make -k check
+ cd ctags
+ mkdir -p testhome
+ export HOME=./testhome
+ export XDG_CONFIG_HOME=
+ make check
}
package() {
- cd "${srcdir}/${_gitname}"
-
- make DESTDIR="${pkgdir}" install
+ cd ctags
+ make DESTDIR="$pkgdir" install
}