summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorroot2022-01-05 16:23:28 +0100
committerroot2022-01-05 16:23:28 +0100
commit8dc87719c26a5090b7d5bb1cc42074642493443c (patch)
tree6a0a5fba4d1efdb3f9f78da61fd30768da12ea45
parent2ff227bb638b8b287ceb56d4387adc761d7efa48 (diff)
downloadaur-8dc87719c26a5090b7d5bb1cc42074642493443c.tar.gz
Added a comment explaining the use case for conditional copying of PNG files to `patched/` directory.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e649a4b4653..0c4a0f14b8d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = universalpaperclips
pkgdesc = Clicker game where you control an AI whose aim is to create as many paperclips as possible. Patched version which loads a colour highlight UI mod if that is installed, and which does not load content from google and with removed external links.
pkgver = 3
- pkgrel = 14
+ pkgrel = 15
url = https://decisionproblem.com/paperclips/
arch = any
license = custom:unknown
diff --git a/PKGBUILD b/PKGBUILD
index f8f43836a0cc..7f67fff031a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname="${_pkgname}"
pkgver=3
_cssver=2
#_cssver="${pkgver}"
-pkgrel=14
+pkgrel=15
pkgdesc='Clicker game where you control an AI whose aim is to create as many paperclips as possible. Patched version which loads a colour highlight UI mod if that is installed, and which does not load content from google and with removed external links.'
arch=('any')
url='https://decisionproblem.com/paperclips/'
@@ -81,10 +81,10 @@ prepare() {
mkdir -p "${srcdir}/patched"
cp "${srcdir}/index.html" "${srcdir}/patched/index.html"
cp "${srcdir}/index2.html" "${srcdir}/patched/index2.html"
- if [ ! -e "${srcdir}/patched/mobile-title.png" ]; then # Copy only if it not already exists, in order to not overwrite already-optimised files from a previous build().
+ if [ ! -e "${srcdir}/patched/mobile-title.png" ]; then # Copy only if it not already exists, in order to not overwrite already-optimised files from a previous build() (useful for subsequent repackaging with `-R` option to skip time consuming PNG optimisation but still use the already optimised files).
cp "${srcdir}/mobile-title.png" "${srcdir}/patched/mobile-title.png"
fi
- if [ ! -e "${srcdir}/patched/title.png" ]; then # Copy only if it not already exists, in order to not overwrite already-optimised files from a previous build().
+ if [ ! -e "${srcdir}/patched/title.png" ]; then # Copy only if it not already exists, in order to not overwrite already-optimised files from a previous build() (useful for subsequent repackaging with `-R` option to skip time consuming PNG optimisation but still use the already optimised files).
cp "${srcdir}/title.png" "${srcdir}/patched/title.png"
fi