summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Hofmann2010-12-19 10:20:07 +0100
committerPeter Hofmann2010-12-19 10:20:07 +0100
commited853af3c7be00dadd8e6ee680ec5a1bff3ae398 (patch)
treeeb7bcdd760ec37b11b0cef20a2efaafa10587ee8
downloadaur-ed853af3c7be00dadd8e6ee680ec5a1bff3ae398.tar.gz
Initial. Also tried to build VT font.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD49
-rw-r--r--univga.install21
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98e7c24dbedd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = univga
+ pkgdesc = Unicode VGA font
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.inp.nsk.su/~bolkhov/files/fonts/univga/
+ install = univga.install
+ arch = any
+ license = MIT
+ makedepends = xorg-font-utils
+ source = http://www.inp.nsk.su/~bolkhov/files/fonts/univga/uni-vga.tgz
+ source = http://ftp.de.debian.org/debian/pool/main/c/console-setup/bdf2psf_1.63_all.deb
+ md5sums = 60fbba53cb0efec1363fcc5fb8c244d9
+ md5sums = 83cfa34b14b8b280c9026ee304277d1c
+
+pkgname = univga
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..178651886d71
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*deb
+*gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..051c3fab560d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+pkgname=univga
+pkgver=1.0
+pkgrel=1
+pkgdesc="Unicode VGA font"
+arch=('any')
+url="http://www.inp.nsk.su/~bolkhov/files/fonts/univga/"
+license=('MIT')
+groups=()
+depends=()
+makedepends=('xorg-font-utils')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=univga.install
+changelog=
+source=('http://www.inp.nsk.su/~bolkhov/files/fonts/univga/uni-vga.tgz'
+ 'http://ftp.de.debian.org/debian/pool/main/c/console-setup/bdf2psf_1.63_all.deb')
+noextract=()
+md5sums=('60fbba53cb0efec1363fcc5fb8c244d9'
+ '83cfa34b14b8b280c9026ee304277d1c')
+
+build() {
+ cd "$srcdir"
+ bsdtar -xf bdf2psf_1.63_all.deb data.tar.gz
+ tar -xzf data.tar.gz
+
+ bdftopcf -o uni_vga/u_vga16.pcf uni_vga/u_vga16.bdf
+
+ usr/bin/bdf2psf --fb uni_vga/u_vga16.bdf \
+ usr/share/bdf2psf/standard.equivalents \
+ usr/share/bdf2psf/required.set+usr/share/bdf2psf/useful.set \
+ 512 \
+ uni_vga/u_vga16.psf
+}
+
+package() {
+ cd "$srcdir"/uni_vga
+
+ install -m 644 -D u_vga16.pcf \
+ "$pkgdir"/usr/share/fonts/local/u_vga16.pcf
+
+ install -m 644 -D u_vga16.psf \
+ "$pkgdir"/usr/share/kbd/consolefonts/u_vga16.psf
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/univga.install b/univga.install
new file mode 100644
index 000000000000..a61db7e4b9a8
--- /dev/null
+++ b/univga.install
@@ -0,0 +1,21 @@
+# arg 1: the new package version
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/local
+ mkfontdir /usr/share/fonts/local
+ echo "done."
+ echo "Note: univga is in /usr/share/fonts/local/"
+}
+
+# # arg 1: the new package version
+# # arg 2: the old package version
+post_upgrade() {
+ post_install $1
+}
+#
+# # arg 1: the old package version
+post_remove() {
+ post_install $1
+}
+