summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2018-10-02 20:50:05 +0200
committerKr1ss2018-10-02 20:50:05 +0200
commita71d58cc78769334ebd50abfd868b14602a3066d (patch)
treeaf229a548bec80ba1af712e9dde5952f3c3518fd
parent860251139b361220cdf931ff52cf6b1056daf1d9 (diff)
downloadaur-a71d58cc78769334ebd50abfd868b14602a3066d.tar.gz
bump to 1.5
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGELOG15
-rw-r--r--PKGBUILD11
3 files changed, 22 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04afc625e9a5..fa2087f2659f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = unix-privesc-check
pkgdesc = Find misconfigurations on UNIX(-like) systems that allow privilege escalation
- pkgver = 1.4
+ pkgver = 1.5
pkgrel = 1
url = http://pentestmonkey.net/tools/audit/unix-privesc-check
changelog = CHANGELOG
arch = any
- license = GPL
+ license = GPL2
license = custom
provides = unix-privesc-check
- source = http://pentestmonkey.net/tools/unix-privesc-check/unix-privesc-check-1.4.tar.gz
- sha256sums = e1f85e7f69fabadd23756a3d76a0e3d864b21e28763b60ce2e6181290d1c1969
+ source = https://github.com/pentestmonkey/unix-privesc-check/archive/r1_5.tar.gz
+ sha256sums = 1435121f4087cc74304498a23f57698fc7eddfca80ca98f032aa009a67c10464
pkgname = unix-privesc-check
diff --git a/CHANGELOG b/CHANGELOG
index 792600896630..d3437a00a71f 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,12 @@
+2009-07-30 unix-privesc-check v1.5
+
+* Initial AIX support added
+* Check for exploit mitigations (Linux only ATM)
+* Brain dumped some more interesting things to check for into TODOs
+* Bug fix: Fixed typos in comments
+* Added SSP exploit mitigation (Linux only ATM)
+
+-- Tim Brown <timb@nth-dimension.org.uk>
2008-11-23 unix-privesc-check v1.4
@@ -21,7 +30,7 @@
* Check of file perms on open file handles of running processes
* Check for running SSH agent. Lists keys if possible.
* Check for public and private SSH keys in home directories.
-* Check for running GPG agent.
+* Check for running GPG agent
* Check for cron jobs in /var/spool/cron/tabs
* Extra non-priv check for local postgres trusts
* Bug fix: lanscan now used on HPUX to get interface names
@@ -30,8 +39,8 @@
2008-04-17 unix-privesc-check v1.1
-* Added check for accounts with no password in /etc/passwd
-* Record some basic info about the host (hostname, uname -a, interface IPs)
+* Added check for accounts with no password in /etc/passwd
+* Record some basic info about the host (hostname, uname -a, interface IPs)
2008-02-01 unix-privesc-check v1.0
diff --git a/PKGBUILD b/PKGBUILD
index 3fa7d6256341..657900f5a7ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Kr1ss <kr1ss.x@yandex.com>
pkgname=unix-privesc-check
-pkgver=1.4
+pkgver=1.5
+_pkgver=r1_5
pkgrel=1
pkgdesc='Find misconfigurations on UNIX(-like) systems that allow privilege escalation'
arch=('any')
url='http://pentestmonkey.net/tools/audit/unix-privesc-check'
-license=('GPL' 'custom')
+license=('GPL2' 'custom')
provides=("$pkgname")
changelog='CHANGELOG'
-source=("http://pentestmonkey.net/tools/unix-privesc-check/$pkgname-$pkgver.tar.gz")
-sha256sums=('e1f85e7f69fabadd23756a3d76a0e3d864b21e28763b60ce2e6181290d1c1969')
+source=("https://github.com/pentestmonkey/unix-privesc-check/archive/$_pkgver.tar.gz")
+sha256sums=('1435121f4087cc74304498a23f57698fc7eddfca80ca98f032aa009a67c10464')
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$_pkgver"
install -Dm644 COPYING.UNIX-PRIVESC-CHECK "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 CHANGELOG "$pkgdir/usr/share/doc/$pkgname/CHANGELOG"
install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"