summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Puntiy2013-04-08 22:16:27 +0300
committerIvan Puntiy2013-04-08 22:16:27 +0300
commit36baad870154a17b0295c1420ac2106cf980c780 (patch)
tree59a0bffbf6d418db1ea94211336c223fe080ce98
downloadaur-36baad870154a17b0295c1420ac2106cf980c780.tar.gz
unix-runescape-client 3.9.10-1
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD43
-rw-r--r--unix-runescape-client.install10
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a46c11e0273
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = unix-runescape-client
+ pkgdesc = RuneScape client for Linux and Unix
+ pkgver = 3.9.10
+ pkgrel = 1
+ url = http://hkprojects.weebly.com/runescape-client-for-linux-and-unix.html
+ install = unix-runescape-client.install
+ arch = any
+ license = GPL2
+ depends = java-runtime
+ depends = perl
+ depends = xterm
+ depends = p7zip
+ optdepends = zenity: better UI
+ optdepends = perl-wx: for rsu-settings
+ optdepends = wine: for "compatibility mode" fix
+ optdepends = alsa-oss: for "force alsa" fix
+ optdepends = pulseaudio: for "force pulseaudio" fix
+ conflicts = runescape-client-bin
+ source = unix-runescape-client-3.9.10.tar.gz::https://github.com/HikariKnight/rsu-client/tarball/v3.9.10
+ md5sums = 99baef5cfb5b5597aeebaa20c3bcf68c
+
+pkgname = unix-runescape-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ccea550f8a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Ivan Puntiy <ivan.puntiy-at-gmail>
+pkgname=unix-runescape-client
+pkgver=3.9.10
+pkgrel=1
+pkgdesc="RuneScape client for Linux and Unix"
+arch=(any)
+url="http://hkprojects.weebly.com/runescape-client-for-linux-and-unix.html"
+license=(GPL2)
+depends=('java-runtime' 'perl' 'xterm' 'p7zip')
+optdepends=(
+ 'zenity: better UI'
+ 'perl-wx: for rsu-settings'
+ 'wine: for "compatibility mode" fix'
+ 'alsa-oss: for "force alsa" fix'
+ 'pulseaudio: for "force pulseaudio" fix'
+)
+conflicts=('runescape-client-bin')
+install=$pkgname.install
+source=("$pkgname-$pkgver.tar.gz::https://github.com/HikariKnight/rsu-client/tarball/v$pkgver")
+
+package() {
+ local _instdir="$pkgdir"/opt/runescape
+ local _hash=$(tar -tf "$srcdir"/$pkgname-$pkgver.tar.gz | head -1 | sed 's:HikariKnight-rsu-client-\([0-9a-fA-F]*\)/:\1:g')
+
+ cd "$srcdir/HikariKnight-rsu-client-$_hash/runescape"
+
+ mkdir -p "$_instdir"/{share,modules} "$pkgdir"/usr/{bin,share/applications}
+
+ # copy the stuff
+ cp -t "$_instdir" *.txt runescape update-runescape-client rsu-settings AUTHORS
+ cp -R share "$_instdir"/
+ cp -R modules "$_instdir"/
+ cp -R templates/packaging/usr/share "$pkgdir"/usr/
+ ## jawt.dll is no longer packaged upstream ##
+ # cp -R win32/jawt "$_instdir"/win32/
+
+ # symlink executables
+ ln -s ../../opt/runescape/runescape "$pkgdir"/usr/bin/runescape
+ ln -s ../../opt/runescape/update-runescape-client "$pkgdir"/usr/bin/update-runescape-client
+ ln -s ../../opt/runescape/rsu-settings "$pkgdir"/usr/bin/rsu-settings
+}
+
+md5sums=('99baef5cfb5b5597aeebaa20c3bcf68c')
diff --git a/unix-runescape-client.install b/unix-runescape-client.install
new file mode 100644
index 000000000000..3caee57f33f9
--- /dev/null
+++ b/unix-runescape-client.install
@@ -0,0 +1,10 @@
+TEXT="==> for compatibility mode to work, you need to install 'wine' and any windows jre inside it.
+"
+
+post_install() {
+ echo $TEXT
+}
+
+post_upgrade() {
+ echo $TEXT
+}