summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Puntiy2014-08-26 00:12:11 +0300
committerIvan Puntiy2014-08-26 00:12:11 +0300
commit5fdc9b652bacb88957ce858dfbc8b0104680a701 (patch)
treec26f656aa598bdea823f4485183c68afcea24328
parent78bc897f1fa0bc19024e2a18ee034bd87ecd1212 (diff)
downloadaur-5fdc9b652bacb88957ce858dfbc8b0104680a701.tar.gz
unix-runescape-client 4.2.9-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
-rw-r--r--rsu-client-4.2.9-combo-fix.patch15
3 files changed, 35 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4df0c667a54a..13e2ae7af559 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = unix-runescape-client
pkgdesc = RuneScape client for Linux and Unix
- pkgver = 4.2.8
- pkgrel = 3
+ pkgver = 4.2.9
+ pkgrel = 1
url = http://hkprojects.weebly.com/runescape-client-for-linux-and-unix.html
install = unix-runescape-client.install
arch = any
@@ -19,8 +19,10 @@ pkgbase = unix-runescape-client
optdepends = p7zip: to extract launcher from .msi
optdepends = cairo-nogl: if game crashes during loading/auto-setup
conflicts = runescape-client-bin
- source = unix-runescape-client-4.2.8.tar.gz::https://github.com/HikariKnight/rsu-client/archive/v4.2.8.tar.gz
- md5sums = 1277f3c56260107cc1231ed7627bda6b
+ source = unix-runescape-client-4.2.9.tar.gz::https://github.com/HikariKnight/rsu-client/archive/v4.2.9.tar.gz
+ source = rsu-client-4.2.9-combo-fix.patch
+ md5sums = 07bab08f979705c7c85a99cd4233654f
+ md5sums = bcfb82e511a902dbcff955bc5bde5fb7
pkgname = unix-runescape-client
diff --git a/PKGBUILD b/PKGBUILD
index f93ce4026da9..65294de8aae9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ivan Puntiy <ivan.puntiy-at-gmail>
pkgname=unix-runescape-client
-pkgver=4.2.8
-pkgrel=3
+pkgver=4.2.9
+pkgrel=1
pkgdesc="RuneScape client for Linux and Unix"
arch=(any)
url="http://hkprojects.weebly.com/runescape-client-for-linux-and-unix.html"
@@ -19,8 +19,18 @@ optdepends=(
)
conflicts=('runescape-client-bin')
install=$pkgname.install
-source=("$pkgname-$pkgver.tar.gz::https://github.com/HikariKnight/rsu-client/archive/v$pkgver.tar.gz")
-md5sums=('1277f3c56260107cc1231ed7627bda6b')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/HikariKnight/rsu-client/archive/v$pkgver.tar.gz"
+ "rsu-client-4.2.9-combo-fix.patch"
+)
+md5sums=('07bab08f979705c7c85a99cd4233654f'
+ 'bcfb82e511a902dbcff955bc5bde5fb7')
+
+prepare() {
+ cd "$srcdir/rsu-client-$pkgver"
+
+ # patch commited upstream: cfb6286ad7fbb36b5745fa7b16cf523cd1fc1cee
+ patch -p1 -i "$srcdir/rsu-client-2.4.9-combo-fix.patch"
+}
package() {
local _instdir="$pkgdir"/opt/runescape
diff --git a/rsu-client-4.2.9-combo-fix.patch b/rsu-client-4.2.9-combo-fix.patch
new file mode 100644
index 000000000000..4dcc937b6723
--- /dev/null
+++ b/rsu-client-4.2.9-combo-fix.patch
@@ -0,0 +1,15 @@
+diff --git a/runescape/rsu/framework/API/client/launch/launcher.pm b/runescape/rsu/framework/API/client/launch/launcher.pm
+index ad9dec3..ce75065 100755
+--- a/runescape/rsu/framework/API/client/launch/launcher.pm
++++ b/runescape/rsu/framework/API/client/launch/launcher.pm
+@@ -2774,7 +2774,9 @@ sub loadprms
+ # Next if filename is runescape.prm, oldschool.prm or runescape-beta.prm
+ #next if $prmfilefound =~ /^(runescape|oldschool|runescape-beta)\.prm$/;
+ # Next if filename ends with .example
+- next if $prmfilefound =~ /\.example$/;
++ #next if $prmfilefound =~ /\.example$/;
++ # Next if filenname does not end with .prm
++ next if $prmfilefound !~ /\.prm$/;
+
+ # Append the file to the combobox
+ $self->{prmSelect}->Append("$prmfilefound");