summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Oelmueller2015-01-02 23:11:09 +0100
committerChris Oelmueller2015-01-02 23:11:09 +0100
commita5dc25d41ecfb1c5e8fc14f009c152ae546b6e6e (patch)
treeeb8711feda8c9d5bc394762e06fb35ba02056659
parentdfe16f7ba73664342df25aea4df7d797683d6ac2 (diff)
downloadaur-a5dc25d41ecfb1c5e8fc14f009c152ae546b6e6e.tar.gz
unknown-horizons 2014.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
-rw-r--r--fix-atlas-overlays.diff13
3 files changed, 36 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7a7756c3363..d48d701e7471 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,25 @@
pkgbase = unknown-horizons
pkgdesc = 2D realtime strategy simulation with an emphasis on economy and city building.
- pkgver = 2013.3
- pkgrel = 6
+ pkgver = 2014.1
+ pkgrel = 1
url = http://www.unknown-horizons.org/
arch = i686
arch = x86_64
license = GPL
license = CCPL
makedepends = intltool
- depends = fife>=0.3.5
+ depends = fife-git
depends = python2
depends = python2-pillow
depends = python2-yaml
conflicts = unknown-horizons-svn
conflicts = unknown-horizons-git
- source = https://github.com/unknown-horizons/unknown-horizons/releases/download/2013.3/unknown-horizons-2013.3.tar.xz
- md5sums = 2417cb88c12a0f855c96743c7f3287d0
- sha256sums = 18c2fd62365e40f6bb06b0a3c4106fff592bac249c3f498d49442f5dc217e37d
+ source = https://github.com/unknown-horizons/unknown-horizons/releases/download/2014.1/unknown-horizons-2014.1.tar.xz
+ source = fix-atlas-overlays.diff::https://github.com/unknown-horizons/unknown-horizons/commit/405c514eab9e2abffe8d1a8912646447e6a29cfa.patch
+ md5sums = 276ed6118eba6af615a286ff2989da6c
+ md5sums = befa5c1525bc0acbdd3b270734d51ff3
+ sha256sums = 5f9dd483e81ad89bff1bc46739349ab531cc930830bf17ef390ac239940a236b
+ sha256sums = f393f8ca09d697ae5dc793b7693f17f3065415cc4ea8a8fabb72dfd8517bec4c
pkgname = unknown-horizons
diff --git a/PKGBUILD b/PKGBUILD
index a297adfb3bd9..8a0fb7fe3de7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,27 +5,28 @@
# Contributor: Deather <deather.jeuxlinux@gmail.com>
# Contributor: Ronan Rabouin <darkbaboon@gmail.com>
pkgname=unknown-horizons
-pkgver=2013.3
-pkgrel=6
+pkgver=2014.1
+pkgrel=1
pkgdesc="2D realtime strategy simulation with an emphasis on economy and city building."
arch=('i686' 'x86_64')
url="http://www.unknown-horizons.org/"
license=('GPL' 'CCPL')
-depends=('fife>=0.3.5' 'python2' 'python2-pillow' 'python2-yaml')
+depends=('fife-git' 'python2' 'python2-pillow' 'python2-yaml')
makedepends=('intltool')
conflicts=('unknown-horizons-svn' 'unknown-horizons-git')
-source=("https://github.com/${pkgname}/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.xz")
-md5sums=('2417cb88c12a0f855c96743c7f3287d0')
-sha256sums=('18c2fd62365e40f6bb06b0a3c4106fff592bac249c3f498d49442f5dc217e37d')
+source=("https://github.com/${pkgname}/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.xz"
+ "fix-atlas-overlays.diff::https://github.com/unknown-horizons/unknown-horizons/commit/405c514eab9e2abffe8d1a8912646447e6a29cfa.patch")
+md5sums=('276ed6118eba6af615a286ff2989da6c'
+ 'befa5c1525bc0acbdd3b270734d51ff3')
+sha256sums=('5f9dd483e81ad89bff1bc46739349ab531cc930830bf17ef390ac239940a236b'
+ 'f393f8ca09d697ae5dc793b7693f17f3065415cc4ea8a8fabb72dfd8517bec4c')
prepare() {
- # Patch new Fife version expecting bool (not int) for logging parameters
- cd "$srcdir/$pkgname"
- sed -i -e 's@\(self._setting.get(SETTINGS.FIFE_MODULE, "LogToPrompt",\) "0"@\1 False@' "horizons/engine/engine.py"
- sed -i -e 's@\(self._setting.get(SETTINGS.FIFE_MODULE, "LogToFile",\) "0"@\1 False@' "horizons/engine/engine.py"
+ cd "$srcdir/$pkgname"
+ # Fix crash with color overlays if using atlases (the default)
+ patch -p1 -i "${srcdir}/fix-atlas-overlays.diff"
}
-
package() {
- cd "$srcdir/$pkgname"
- python2 setup.py --quiet install --root="$pkgdir" --optimize=1
+ cd "$srcdir/$pkgname"
+ python2 setup.py --quiet install --root="$pkgdir" --optimize=1
}
diff --git a/fix-atlas-overlays.diff b/fix-atlas-overlays.diff
new file mode 100644
index 000000000000..324c5c04ca6b
--- /dev/null
+++ b/fix-atlas-overlays.diff
@@ -0,0 +1,13 @@
+diff --git a/horizons/component/coloroverlaycomponent.py b/horizons/component/coloroverlaycomponent.py
+index 23d138b..41bbbff 100644
+--- a/horizons/component/coloroverlaycomponent.py
++++ b/horizons/component/coloroverlaycomponent.py
+@@ -166,7 +166,7 @@ def add_overlay(self, overlay_name, z_order):
+ except TypeError:
+ # not using atlases
+ frame_length = frame_data
+- pic = horizons.globals.fife.imagemanager.load(frame_img)
++ pic = horizons.globals.fife.animationloader.load_image(frame_img, self.action_set, overlay_name, rotation)
+ frame_milliseconds = int(frame_length * 1000)
+ ov_anim.addFrame(pic, frame_milliseconds)
+ overlay = fife.OverlayColors(ov_anim)