summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2019-01-23 17:05:07 +0100
committerLucki2019-01-23 17:05:07 +0100
commita9cd17268662b8c5d8c3f01a1b61391af7639a22 (patch)
treeed815ccdb5d0ec0a953156e4849e8275f569480f
parent23d441992c6977fb25e3de516d5ff83c4191f1b9 (diff)
downloadaur-a9cd17268662b8c5d8c3f01a1b61391af7639a22.tar.gz
Enhance PKGBUILD
- Clean up dependencies - Don't strictly depend on the *-git dependencies - Correct $arch - Replace the wrong used replace with provides - Don't clutter $USERs home by setting $HOME temporary to the build folder
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 24 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a38ddf8b0c1..962836acd398 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,21 @@
pkgbase = unknown-horizons-git
pkgdesc = Open source real-time strategy game with the comfy Anno1602 feeling.
pkgver = 2017.2.373.g8319a4773
- pkgrel = 1
+ pkgrel = 2
url = http://www.unknown-horizons.org
- arch = i686
- arch = x86_64
+ arch = any
license = GPL
license = CCPL
makedepends = git
makedepends = intltool
- depends = fife-git
- depends = python
+ depends = fife
depends = python-yaml
depends = python-pillow
depends = python-future
- conflicts = unknown-horizons-svn
+ provides = unknown-horizons
conflicts = unknown-horizons
- replaces = unknown-horizons-svn
- replaces = unknown-horizons
- source = git://github.com/unknown-horizons/unknown-horizons.git
- md5sums = SKIP
+ source = git+https://github.com/unknown-horizons/unknown-horizons.git
+ sha512sums = SKIP
pkgname = unknown-horizons-git
diff --git a/PKGBUILD b/PKGBUILD
index 37efddfca297..1779efdf7fc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,33 @@
-# Maintainer: Chris Oelmueller <chris.oelmueller@gmail.com>
+# Maintainer: Lucki <https://aur.archlinux.org/account/Lucki>
+# Contributor: Chris Oelmueller <chris.oelmueller@gmail.com>
# Contributor: Thomas Kinnen <thomas.kinnen@gmail.com>
# Contributor: Thomas Kowaliczek-Schmer <thomas.kowaliczek@posteo.de>
pkgname=unknown-horizons-git
pkgver=2017.2.373.g8319a4773
-pkgrel=1
+pkgrel=2
pkgdesc="Open source real-time strategy game with the comfy Anno1602 feeling."
-arch=("i686" "x86_64")
+arch=('any')
url="http://www.unknown-horizons.org"
license=('GPL' 'CCPL')
-depends=('fife-git' 'python' 'python-yaml' 'python-pillow' 'python-future' )
+depends=('fife' 'python-yaml' 'python-pillow' 'python-future')
makedepends=('git' 'intltool')
-conflicts=('unknown-horizons-svn' 'unknown-horizons')
-replaces=('unknown-horizons-svn' 'unknown-horizons')
-source=("git://github.com/unknown-horizons/unknown-horizons.git")
-md5sums=('SKIP')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
+source=("git+https://github.com/${pkgname%-git}/${pkgname%-git}.git")
+sha512sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-*}"
- git describe --tags --match "20[0-9][0-9]\.[0-9]" | sed 's/-/./g'
+ cd "$srcdir/${pkgname%-git}"
+ git describe --tags --match "[0-9][0-9][0-9][0-9]\.[0-9]" | sed 's/-/./g'
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ HOME=. python setup.py build
}
package() {
- cd "$srcdir/${pkgname%-*}"
- python setup.py install --root="$pkgdir" --optimize=1
+ cd "$srcdir/${pkgname%-git}"
+ HOME=. python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}