summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2019-04-29 14:04:12 +0200
committerLucki2019-04-29 14:04:12 +0200
commitd86e1348301e5d69bfc1817ba1f06c595e1f7749 (patch)
treebb4fe837655bb62d887b60b25f67cdd2ac07a522
parenta9cd17268662b8c5d8c3f01a1b61391af7639a22 (diff)
downloadaur-d86e1348301e5d69bfc1817ba1f06c595e1f7749.tar.gz
Use the correct version string
from development/create_release_tarball.sh.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 962836acd398..c58cebb28d32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = unknown-horizons-git
pkgdesc = Open source real-time strategy game with the comfy Anno1602 feeling.
- pkgver = 2017.2.373.g8319a4773
- pkgrel = 2
+ pkgver = 2019.1.r43.gc2eee6a20
+ pkgrel = 1
url = http://www.unknown-horizons.org
arch = any
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 1779efdf7fc3..f6b6d9eae88d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Thomas Kowaliczek-Schmer <thomas.kowaliczek@posteo.de>
pkgname=unknown-horizons-git
-pkgver=2017.2.373.g8319a4773
-pkgrel=2
+pkgver=2019.1.r43.gc2eee6a20
+pkgrel=1
pkgdesc="Open source real-time strategy game with the comfy Anno1602 feeling."
arch=('any')
url="http://www.unknown-horizons.org"
@@ -19,12 +19,14 @@ sha512sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
- git describe --tags --match "[0-9][0-9][0-9][0-9]\.[0-9]" | sed 's/-/./g'
+ printf "%s.%s" \
+ "$(egrep -o 'RELEASE_VERSION=[0-9]+\.[0-9]+' < development/create_release_tarball.sh | sed -r 's/RELEASE_VERSION=//g')" \
+ "$(git describe --long --tags | awk -F '-' '{print "r" $(NF-1) "." $(NF)}')"
}
build() {
- cd "$srcdir/${pkgname%-git}"
- HOME=. python setup.py build
+ cd "$srcdir/${pkgname%-git}"
+ HOME=. python setup.py build
}
package() {