summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2019-06-09 16:16:28 +0200
committerLucki2019-06-09 16:16:28 +0200
commite3e3a9d800a12d31d7c8b57d9901c5117d27c853 (patch)
tree6a76e4017329a1f08347c60f04a1d720ad46915a
parentd86e1348301e5d69bfc1817ba1f06c595e1f7749 (diff)
downloadaur-e3e3a9d800a12d31d7c8b57d9901c5117d27c853.tar.gz
Minor improvements
- remove build step so all files are getting picked up by the build system - manually generate atlases as it's somehow missing
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD23
2 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c58cebb28d32..b89c143d7d07 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = unknown-horizons-git
pkgdesc = Open source real-time strategy game with the comfy Anno1602 feeling.
- pkgver = 2019.1.r43.gc2eee6a20
+ pkgver = 2019.1.r47.gc196f0704
pkgrel = 1
url = http://www.unknown-horizons.org
arch = any
@@ -8,6 +8,7 @@ pkgbase = unknown-horizons-git
license = CCPL
makedepends = git
makedepends = intltool
+ makedepends = python-setuptools
depends = fife
depends = python-yaml
depends = python-pillow
diff --git a/PKGBUILD b/PKGBUILD
index f6b6d9eae88d..afb5f28b9494 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,32 +4,35 @@
# Contributor: Thomas Kowaliczek-Schmer <thomas.kowaliczek@posteo.de>
pkgname=unknown-horizons-git
-pkgver=2019.1.r43.gc2eee6a20
+pkgver=2019.1.r47.gc196f0704
pkgrel=1
pkgdesc="Open source real-time strategy game with the comfy Anno1602 feeling."
arch=('any')
url="http://www.unknown-horizons.org"
license=('GPL' 'CCPL')
depends=('fife' 'python-yaml' 'python-pillow' 'python-future')
-makedepends=('git' 'intltool')
+makedepends=('git' 'intltool' 'python-setuptools')
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
source=("git+https://github.com/${pkgname%-git}/${pkgname%-git}.git")
sha512sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- printf "%s.%s" \
- "$(egrep -o 'RELEASE_VERSION=[0-9]+\.[0-9]+' < development/create_release_tarball.sh | sed -r 's/RELEASE_VERSION=//g')" \
- "$(git describe --long --tags | awk -F '-' '{print "r" $(NF-1) "." $(NF)}')"
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s.%s" \
+ "$(egrep -o 'RELEASE_VERSION=[0-9]+\.[0-9]+' < development/create_release_tarball.sh | sed -r 's/RELEASE_VERSION=//g')" \
+ "$(git describe --long --tags | awk -F '-' '{print "r" $(NF-1) "." $(NF)}')"
}
+# unknown-horizons build system misses a few files if the build step is seperated from the install
+# step
build() {
- cd "$srcdir/${pkgname%-git}"
- HOME=. python setup.py build
+ cd "$srcdir/${pkgname%-git}"
+ # HOME=. python setup.py build
+ HOME=. python horizons/engine/generate_atlases.py 2048
}
package() {
- cd "$srcdir/${pkgname%-git}"
- HOME=. python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ cd "$srcdir/${pkgname%-git}"
+ HOME=. python setup.py install --root="$pkgdir/" --optimize=1 #--skip-build
}