summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjoel2015-06-17 23:44:52 +0200
committerjoel2015-06-17 23:44:52 +0200
commit20ac9db7dfefc1b635831c6bdce142b46bd6cc90 (patch)
treeef3b836f8b429815b80cfe1fde898c48f4eee438
downloadaur-unqlite-unofficial.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--LICENSE25
-rw-r--r--PKGBUILD37
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ddda7bc91cea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = unqlite-unofficial
+ pkgdesc = Embeddable NoSQL DB Engine library with unofficial patches from the tocc project (http://t-o-c-c.com)
+ pkgver = 1.1.6
+ pkgrel = 2
+ url = http://unqlite.org
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = glibc
+ optdepends = unqlite-doc: official documentation
+ provides = unqlite-lib
+ conflicts = unqlite
+ conflicts = unqlite-lib
+ conflicts = unqlite-interp
+ conflicts = unqlite-samples
+ source = https://github.com/aidin36/tocc/releases/download/v1.0.1/unqlite-unofficial-1.1.6.tar.gz
+ source = LICENSE
+ sha256sums = 7acc88b500f6ceeb622fd65e161b59e4cd3ce6c12678762bc04dbd121edc77e9
+ sha256sums = 643698d5116871a69553fe323b93c8ac5043d244d01f59772d8be4aeaafef2bc
+ sha384sums = 00b949e8fc07f6dd360e4578c3c568b288c3c8c2ed3dbd55eac3a01c18c9cc1648b2d040e16bb52a39ee9841efc829fa
+ sha384sums = 77bb30418f4c33b91280c20ebfd652126441bd054172a1186574cbe44ddda87981cbb6b1850487be41d67a418cea9046
+ sha512sums = a781a257f8d16d638b0a2f1f48a265fe9f7dec444d81e1048b5dfb4d8b38796151b0e8271c656b542e15aea7d22bedde847e2d0569379cdfa9b2360ba9209212
+ sha512sums = ad8e3962c5037598ba6d88c04c70fab626b1ae9498c4cab7710d2eb962108ff55349b0f113750d3380cd75d294bfb499cdc59ae7db0a9deb51a85e19f7ac1343
+
+pkgname = unqlite-unofficial
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..968624ca1bf6
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,25 @@
+/*
+ * Copyright (C) 2012, 2013 Symisc Systems, S.U.A.R.L [M.I.A.G Mrad Chems Eddine <chm@symisc.net>].
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * THIS SOFTWARE IS PROVIDED BY SYMISC SYSTEMS ``AS IS'' AND ANY EXPRESS
+ * OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+ * WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR
+ * NON-INFRINGEMENT, ARE DISCLAIMED. IN NO EVENT SHALL SYMISC SYSTEMS
+ * BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+ * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+ * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
+ * BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+ * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE
+ * OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
+ * IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3daa9d6d3c60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: yozi <es.mslj TA xunilhcra> backwards
+# Contributor: yozi <es.mslj TA xunilhcra> backwards
+pkgname='unqlite-unofficial'
+pkgver='1.1.6'
+pkgrel=2
+pkgdesc='Embeddable NoSQL DB Engine library with unofficial patches from the tocc project (http://t-o-c-c.com)'
+arch=('i686' 'x86_64')
+url='http://unqlite.org'
+license=('BSD')
+depends=('glibc')
+conflicts=('unqlite' 'unqlite-lib' 'unqlite-interp' 'unqlite-samples')
+provides=('unqlite-lib')
+optdepends=('unqlite-doc: official documentation')
+source=("https://github.com/aidin36/tocc/releases/download/v1.0.1/${pkgname}-${pkgver}.tar.gz"
+ "LICENSE")
+validpgpkeys=(# Aidin Gharibnavaz <aidin@t-o-c-c.com>
+ 'FC34B251315AF6668AA1FB30F8A5FC9979B75433')
+sha256sums=('7acc88b500f6ceeb622fd65e161b59e4cd3ce6c12678762bc04dbd121edc77e9'
+ '643698d5116871a69553fe323b93c8ac5043d244d01f59772d8be4aeaafef2bc')
+sha384sums=('00b949e8fc07f6dd360e4578c3c568b288c3c8c2ed3dbd55eac3a01c18c9cc1648b2d040e16bb52a39ee9841efc829fa'
+ '77bb30418f4c33b91280c20ebfd652126441bd054172a1186574cbe44ddda87981cbb6b1850487be41d67a418cea9046')
+sha512sums=('a781a257f8d16d638b0a2f1f48a265fe9f7dec444d81e1048b5dfb4d8b38796151b0e8271c656b542e15aea7d22bedde847e2d0569379cdfa9b2360ba9209212'
+ 'ad8e3962c5037598ba6d88c04c70fab626b1ae9498c4cab7710d2eb962108ff55349b0f113750d3380cd75d294bfb499cdc59ae7db0a9deb51a85e19f7ac1343')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
+}
+
+# vim:set ts=2 sw=2 et: