summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Holthuis2015-06-21 19:42:34 +0200
committerJan Holthuis2015-06-21 19:42:34 +0200
commit391eb3b2ddd84a98bbbe4da1756c040bc5c6b275 (patch)
treecc39ea2a7cade9ec54b85a7f499143d7320a19fb
downloadaur-391eb3b2ddd84a98bbbe4da1756c040bc5c6b275.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..37d25faeec25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = unrarall-git
+ pkgdesc = unrarall is a utility to unrar and clean up various files (.e.g. rar files).
+ pkgver = 0.0.0
+ pkgrel = 2
+ url = https://github.com/arfoll/unrarall
+ arch = any
+ license = GPL3
+ makedepends = git
+ optdepends = unrar: unrar support
+ optdepends = 7z: 7z support
+ optdepends = cksfv: CRC check before extracting
+ provides = unrarall
+ conflicts = unrarall
+ source = git+https://github.com/arfoll/unrarall.git
+ md5sums = SKIP
+
+pkgname = unrarall-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09bb7f8806a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jan Holthuis <holthuis.jan@googlemail.com>
+pkgname=unrarall-git
+pkgver=0.0.0
+pkgrel=2
+pkgdesc="unrarall is a utility to unrar and clean up various files (.e.g. rar files)."
+arch=('any')
+url="https://github.com/arfoll/unrarall"
+license=('GPL3')
+optdepends=('unrar: unrar support'
+ '7z: 7z support'
+ 'cksfv: CRC check before extracting')
+makedepends=('git')
+conflicts=('unrarall')
+provides=('unrarall')
+# The git repo is detected by the 'git:' or 'git+' beginning. The branch
+# '$pkgname' is then checked out upon cloning, expediating versioning:
+source=('git+https://github.com/arfoll/unrarall.git')
+# Because the sources are not static, skip Git checksum:
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/unrarall"
+ # Use the tag of the last commit
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ install -Dm755 "$srcdir/unrarall/unrarall" "$pkgdir/usr/bin/unrarall"
+}